Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "File synchronization tool" |
| 2 | HOMEPAGE = "http://rsync.samba.org/" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 3 | DESCRIPTION = "rsync is an open source utility that provides fast incremental file transfer." |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | BUGTRACKER = "http://rsync.samba.org/bugzilla.html" |
| 5 | SECTION = "console/network" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | # GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0) |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 7 | # Includes opennsh and xxhash dynamic link exception |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 8 | LICENSE = "GPLv3+" |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=9e5a4f9b3a253d51520617aa54f8eb26" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 10 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | DEPENDS = "popt" |
| 12 | |
| 13 | SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \ |
| 14 | file://rsyncd.conf \ |
| 15 | file://makefile-no-rebuild.patch \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 16 | file://determism.patch \ |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 17 | file://0001-rsync-ssl-Verify-the-hostname-in-the-certificate-whe.patch \ |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 18 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 20 | SRC_URI[sha256sum] = "becc3c504ceea499f4167a260040ccf4d9f2ef9499ad5683c179a697146ce50e" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | # -16548 required for v3.1.3pre1. Already in v3.1.3. |
| 23 | CVE_CHECK_WHITELIST += " CVE-2017-16548 " |
| 24 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 25 | inherit autotools-brokensep |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 27 | PACKAGECONFIG ??= "acl attr \ |
| 28 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ |
| 29 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 31 | PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl," |
| 32 | PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr," |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 34 | PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4" |
| 35 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| 36 | PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash" |
| 37 | PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 38 | |
| 39 | # By default, if crosscompiling, rsync disables a number of |
| 40 | # capabilities, hardlinking symlinks and special files (i.e. devices) |
| 41 | CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes" |
| 42 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 43 | EXTRA_OEMAKE = 'STRIP=""' |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 44 | EXTRA_OECONF = "--disable-simd --disable-md2man --disable-asm --with-nobody-group=nogroup" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 45 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 46 | # rsync 3.0 uses configure.sh instead of configure, and |
| 47 | # makefile checks the existence of configure.sh |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 48 | do_configure:prepend () { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 49 | rm -f ${S}/configure ${S}/configure.sh |
| 50 | } |
| 51 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 52 | do_configure:append () { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 53 | cp -f ${S}/configure ${S}/configure.sh |
| 54 | } |
| 55 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 56 | do_install:append() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 57 | install -d ${D}${sysconfdir} |
| 58 | install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir} |
| 59 | } |
| 60 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 61 | BBCLASSEXTEND = "native nativesdk" |