Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "NVMe management command line interface" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://github.com/linux-nvme/nvme-cli" |
| 3 | SECTION = "console/utils" |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 4 | LICENSE = "GPL-2.0-only & CC0-1.0 & MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022 \ |
| 6 | file://ccan/licenses/CC0;md5=c17af43b05840255a6fedc5eda9d56cc \ |
| 7 | file://ccan/licenses/BSD-MIT;md5=838c366f69b72c5df05c96dff79b35f2" |
| 8 | DEPENDS = "json-c libnvme" |
Andrew Geissler | 2013739 | 2023-10-12 04:59:14 -0600 | [diff] [blame^] | 9 | SRCREV = "bd2f882a49a14b0e21a94c928128b1979e4316fd" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | SRC_URI = "git://github.com/linux-nvme/nvme-cli.git;branch=master;protocol=https" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 15 | inherit bash-completion meson pkgconfig systemd |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 17 | EXTRA_OEMESON += "-Dsystemddir=${systemd_unitdir}/system" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 19 | pkg_postinst_ontarget:${PN}() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | ${sbindir}/nvme gen-hostnqn > ${sysconfdir}/nvme/hostnqn |
| 21 | ${bindir}/uuidgen > ${sysconfdir}/nvme/hostid |
| 22 | } |
| 23 | |
| 24 | PACKAGES =+ "${PN}-dracut ${PN}-zsh-completion" |
| 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | FILES:${PN} += "${systemd_system_unitdir}" |
| 27 | FILES:${PN}-dracut = "${nonarch_libdir}/dracut/dracut.conf.d" |
| 28 | FILES:${PN}-zsh-completion = "${datadir}/zsh/site-functions" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | RDEPENDS:${PN} = "util-linux-uuidgen" |