Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Python wrapper around rapidjson" |
| 2 | HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson" |
| 3 | |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd" |
| 6 | |
| 7 | SRC_URI = "git://github.com/python-rapidjson/python-rapidjson.git;protocol=https;branch=master" |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 8 | SRCREV = "e1b41f64df1705770b7b70d7221a4812909c1d0f" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
Andrew Geissler | 2013739 | 2023-10-12 04:59:14 -0600 | [diff] [blame^] | 12 | # Inheriting ptest provides functionality for packaging and installing runtime tests for this recipe |
| 13 | inherit setuptools3 ptest |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 14 | |
| 15 | SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}" |
| 16 | |
Andrew Geissler | 2013739 | 2023-10-12 04:59:14 -0600 | [diff] [blame^] | 17 | # run-ptest is a shell script that starts the test suite |
| 18 | SRC_URI += " \ |
| 19 | file://run-ptest \ |
| 20 | " |
| 21 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 22 | DEPENDS += " \ |
| 23 | rapidjson \ |
| 24 | " |
| 25 | |
Andrew Geissler | 2013739 | 2023-10-12 04:59:14 -0600 | [diff] [blame^] | 26 | # Adding required python package for the ptest (pytest and pytest->automake report translation) |
| 27 | RDEPENDS:${PN}-ptest += " \ |
| 28 | ${PYTHON_PN}-pytest \ |
| 29 | ${PYTHON_PN}-unittest-automake-output \ |
| 30 | " |
| 31 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 32 | RDEPENDS:${PN} += " \ |
| 33 | ${PYTHON_PN}-core \ |
| 34 | " |
Andrew Geissler | 2013739 | 2023-10-12 04:59:14 -0600 | [diff] [blame^] | 35 | |
| 36 | # Installing the test suite on the target |
| 37 | do_install_ptest() { |
| 38 | install -d ${D}${PTEST_PATH}/tests |
| 39 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 40 | } |