blob: 3ea55948876d5cde4bbe3c8b5d574d75906196ea [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python wrapper around rapidjson"
2HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd"
6
7SRC_URI = "git://github.com/python-rapidjson/python-rapidjson.git;protocol=https;branch=master"
Andrew Geissler220dafd2023-10-04 10:18:08 -05008SRCREV = "e1b41f64df1705770b7b70d7221a4812909c1d0f"
Andrew Geissler517393d2023-01-13 08:55:19 -06009
10S = "${WORKDIR}/git"
11
Andrew Geissler20137392023-10-12 04:59:14 -060012# Inheriting ptest provides functionality for packaging and installing runtime tests for this recipe
13inherit setuptools3 ptest
Andrew Geissler517393d2023-01-13 08:55:19 -060014
15SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}"
16
Andrew Geissler20137392023-10-12 04:59:14 -060017# run-ptest is a shell script that starts the test suite
18SRC_URI += " \
19 file://run-ptest \
20"
21
Andrew Geissler517393d2023-01-13 08:55:19 -060022DEPENDS += " \
23 rapidjson \
24"
25
Andrew Geissler20137392023-10-12 04:59:14 -060026# Adding required python package for the ptest (pytest and pytest->automake report translation)
27RDEPENDS:${PN}-ptest += " \
28 ${PYTHON_PN}-pytest \
29 ${PYTHON_PN}-unittest-automake-output \
30"
31
Andrew Geissler517393d2023-01-13 08:55:19 -060032RDEPENDS:${PN} += " \
33 ${PYTHON_PN}-core \
34"
Andrew Geissler20137392023-10-12 04:59:14 -060035
36# Installing the test suite on the target
37do_install_ptest() {
38 install -d ${D}${PTEST_PATH}/tests
39 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
40}