Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "HTTP/2 C Library and tools" |
| 2 | HOMEPAGE = "https://nghttp2.org/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec" |
| 6 | |
| 7 | SRC_URI = "\ |
| 8 | ${GITHUB_BASE_URI}/download/v${PV}/nghttp2-${PV}.tar.xz \ |
| 9 | file://0001-fetch-ocsp-response-use-python3.patch \ |
| 10 | " |
Andrew Geissler | 2013739 | 2023-10-12 04:59:14 -0600 | [diff] [blame^] | 11 | SRC_URI[sha256sum] = "9210b0113109f43be526ac5835d58a701411821a4d39e155c40d67c40f47a958" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | |
| 13 | inherit cmake manpages python3native github-releases |
| 14 | PACKAGECONFIG[manpages] = "" |
| 15 | |
| 16 | # examples are never installed, and don't need to be built in the |
| 17 | # first place |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 18 | EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF -DENABLE_PYTHON_BINDINGS=OFF" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 19 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 20 | PACKAGES =+ "lib${BPN} ${PN}-proxy " |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 21 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 22 | RDEPENDS:${PN} = "${PN}-proxy (>= ${PV})" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 23 | RDEPENDS:${PN}:class-native = "" |
| 24 | RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell" |
| 25 | |
| 26 | ALLOW_EMPTY:${PN} = "1" |
| 27 | FILES:${PN} = "" |
| 28 | FILES:lib${BPN} = "${libdir}/*${SOLIBS}" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 29 | FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |