Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "A GObject-based Exiv2 wrapper" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 2 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=625f055f41728f84a8d7938acc35bdc2" |
| 4 | |
| 5 | DEPENDS = "exiv2 python3-pygobject-native" |
| 6 | |
| 7 | GNOMEBASEBUILDCLASS = "meson" |
| 8 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 9 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame^] | 10 | inherit gnomebase gobject-introspection gtk-doc python3native vala |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame^] | 12 | SRC_URI[archive.sha256sum] = "2a0c9cf48fbe8b3435008866ffd40b8eddb0667d2212b42396fdf688e93ce0be" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | |
| 14 | EXTRA_OEMESON = " \ |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame^] | 15 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-Dvapi=true', '-Dvapi=false', d)} \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | PACKAGES =+ "${PN}-python3" |
| 19 | FILES:${PN}-python3 = "${PYTHON_SITEPACKAGES_DIR}" |
| 20 | RDEPENDS:${PN}-python3 = "${PN}" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 21 | |
| 22 | PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess" |
| 23 | src_package_preprocess () { |
| 24 | # Trim build paths from comments in generated sources to ensure reproducibility |
| 25 | sed -i -e "s,${B}/../${BPN}-${PV}/${BPN}/,,g" \ |
| 26 | ${B}/gexiv2/gexiv2-enums.cpp |
| 27 | } |