Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Kernel selftest for Linux" |
| 2 | DESCRIPTION = "Kernel selftest for Linux" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "GPL-2.0-only" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | |
| 5 | LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |
| 6 | |
| 7 | DEPENDS = "rsync-native llvm-native" |
| 8 | |
| 9 | # for musl libc |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 10 | SRC_URI:append:libc-musl = "\ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | file://userfaultfd.patch \ |
| 12 | " |
| 13 | SRC_URI += "file://run-ptest \ |
| 14 | file://COPYING \ |
| 15 | " |
| 16 | |
| 17 | # now we just test bpf and vm |
| 18 | # we will append other kernel selftest in the future |
| 19 | # bpf was added in 4.10 with: https://github.com/torvalds/linux/commit/5aa5bd14c5f8660c64ceedf14a549781be47e53d |
| 20 | # if you have older kernel than that you need to remove it from PACKAGECONFIG |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | PACKAGECONFIG ??= "firmware" |
| 22 | PACKAGECONFIG:remove:x86 = "bpf" |
| 23 | PACKAGECONFIG:remove:arm = "bpf vm" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | # host ptrace.h is used to compile BPF target but mips ptrace.h is needed |
| 25 | # progs/loop1.c:21:9: error: incomplete definition of type 'struct user_pt_regs' |
| 26 | # m = PT_REGS_RC(ctx); |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 27 | # vm tests need libhugetlbfs starting 5.8+ (https://lkml.org/lkml/2020/4/22/1654) |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | PACKAGECONFIG:remove:qemumips = "bpf vm" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 30 | # riscv does not support libhugetlbfs yet |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | PACKAGECONFIG:remove:riscv64 = "vm" |
| 32 | PACKAGECONFIG:remove:riscv32 = "vm" |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 33 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 34 | PACKAGECONFIG[bpf] = ",,elfutils libcap libcap-ng rsync-native," |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | PACKAGECONFIG[firmware] = ",,libcap, bash" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 36 | PACKAGECONFIG[vm] = ",,libcap libhugetlbfs,libgcc bash" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 37 | |
| 38 | do_patch[depends] += "virtual/kernel:do_shared_workdir" |
| 39 | |
| 40 | inherit linux-kernel-base kernel-arch ptest |
| 41 | |
| 42 | S = "${WORKDIR}/${BP}" |
| 43 | |
| 44 | TEST_LIST = "\ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 45 | ${@bb.utils.filter('PACKAGECONFIG', 'bpf firmware vm', d)} \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 46 | rtc \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 47 | " |
| 48 | |
| 49 | EXTRA_OEMAKE = '\ |
| 50 | CROSS_COMPILE=${TARGET_PREFIX} \ |
| 51 | ARCH=${ARCH} \ |
| 52 | CC="${CC}" \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 53 | CLANG="clang -fno-stack-protector -target ${TARGET_ARCH} ${TOOLCHAIN_OPTIONS}" \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 54 | AR="${AR}" \ |
| 55 | LD="${LD}" \ |
| 56 | DESTDIR="${D}" \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 57 | MACHINE="${ARCH}" \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 58 | ' |
| 59 | |
| 60 | KERNEL_SELFTEST_SRC ?= "Makefile \ |
| 61 | include \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 62 | kernel \ |
| 63 | lib \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 64 | tools \ |
| 65 | scripts \ |
| 66 | arch \ |
| 67 | LICENSES \ |
| 68 | " |
| 69 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 70 | do_compile() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 71 | if [ ${@bb.utils.contains('PACKAGECONFIG', 'bpf', 'True', 'False', d)} = 'True' ]; then |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 72 | if [ ${@bb.utils.contains('DEPENDS', 'clang-native', 'True', 'False', d)} = 'False' ]; then |
| 73 | bbwarn "clang >= 6.0 with bpf support is needed with kernel 4.18+ so |
| 74 | either install it and add it to HOSTTOOLS, or add clang-native from meta-clang to dependency" |
| 75 | fi |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 76 | fi |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame^] | 77 | oe_runmake -C ${S} headers |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 78 | for i in ${TEST_LIST} |
| 79 | do |
| 80 | oe_runmake -C ${S}/tools/testing/selftests/${i} |
| 81 | done |
| 82 | } |
| 83 | |
| 84 | do_install() { |
| 85 | for i in ${TEST_LIST} |
| 86 | do |
| 87 | oe_runmake -C ${S}/tools/testing/selftests/${i} INSTALL_PATH=${D}/usr/kernel-selftest/${i} install |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 88 | # Install kselftest-list.txt that required by kselftest runner. |
| 89 | oe_runmake -s --no-print-directory COLLECTION=${i} -C ${S}/tools/testing/selftests/${i} emit_tests \ |
| 90 | >> ${D}/usr/kernel-selftest/kselftest-list.txt |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 91 | done |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 92 | # Install kselftest runner. |
| 93 | install -m 0755 ${S}/tools/testing/selftests/run_kselftest.sh ${D}/usr/kernel-selftest/ |
| 94 | cp -R --no-dereference --preserve=mode,links -v ${S}/tools/testing/selftests/kselftest ${D}/usr/kernel-selftest/ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 95 | if [ -e ${D}/usr/kernel-selftest/bpf/test_offload.py ]; then |
| 96 | sed -i -e '1s,#!.*python3,#! /usr/bin/env python3,' ${D}/usr/kernel-selftest/bpf/test_offload.py |
| 97 | fi |
| 98 | chown root:root -R ${D}/usr/kernel-selftest |
| 99 | } |
| 100 | |
| 101 | do_configure() { |
| 102 | install -D -m 0644 ${WORKDIR}/COPYING ${S}/COPYING |
| 103 | } |
| 104 | |
| 105 | do_patch[prefuncs] += "copy_kselftest_source_from_kernel remove_unrelated" |
| 106 | python copy_kselftest_source_from_kernel() { |
| 107 | sources = (d.getVar("KERNEL_SELFTEST_SRC") or "").split() |
| 108 | src_dir = d.getVar("STAGING_KERNEL_DIR") |
| 109 | dest_dir = d.getVar("S") |
| 110 | bb.utils.mkdirhier(dest_dir) |
| 111 | for s in sources: |
| 112 | src = oe.path.join(src_dir, s) |
| 113 | dest = oe.path.join(dest_dir, s) |
| 114 | if os.path.isdir(src): |
| 115 | oe.path.copytree(src, dest) |
| 116 | else: |
| 117 | bb.utils.copyfile(src, dest) |
| 118 | } |
| 119 | |
| 120 | remove_unrelated() { |
| 121 | if ${@bb.utils.contains('PACKAGECONFIG','bpf','true','false',d)} ; then |
| 122 | test -f ${S}/tools/testing/selftests/bpf/Makefile && \ |
| 123 | sed -i -e 's/test_pkt_access.*$/\\/' \ |
| 124 | -e 's/test_pkt_md_access.*$/\\/' \ |
| 125 | -e 's/sockmap_verdict_prog.*$/\\/' \ |
| 126 | ${S}/tools/testing/selftests/bpf/Makefile || \ |
| 127 | bberror "Your kernel is probably older than 4.10 and doesn't have tools/testing/selftests/bpf/Makefile file from https://github.com/torvalds/linux/commit/5aa5bd14c5f8660c64ceedf14a549781be47e53d, disable bpf PACKAGECONFIG" |
| 128 | fi |
| 129 | } |
| 130 | |
| 131 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 132 | |
| 133 | INHIBIT_PACKAGE_DEBUG_SPLIT="1" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 134 | FILES:${PN} += "/usr/kernel-selftest" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 135 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 136 | RDEPENDS:${PN} += "python3 perl" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 137 | # tools/testing/selftests/vm/Makefile doesn't respect LDFLAGS and tools/testing/selftests/Makefile explicitly overrides to empty |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 138 | INSANE_SKIP:${PN} += "ldflags" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 139 | |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 140 | SECURITY_CFLAGS = "" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 141 | COMPATIBLE_HOST:libc-musl = 'null' |
Brad Bishop | 5f78ea1 | 2019-09-10 07:20:03 -0400 | [diff] [blame] | 142 | |
Brad Bishop | dec060e | 2019-09-23 08:01:31 -0400 | [diff] [blame] | 143 | # It has native clang/llvm dependency, poky distro is reluctant to include them as deps |
| 144 | # this helps with world builds on AB |
| 145 | EXCLUDE_FROM_WORLD = "1" |