blob: 772a51462c9beda9181f89eb42908642450ec712 [file] [log] [blame]
Joel Stanley88aae3e2018-05-11 15:16:32 +09301SUMMARY = "OpenPower Hostboot Boot settings tool"
2PR = "r1"
Brad Bishop2879d322018-11-07 14:45:23 -05003LICENSE = "Apache-2.0"
Brad Bishop1ebdb612019-09-13 12:18:25 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Joel Stanley88aae3e2018-05-11 15:16:32 +09305
Joel Stanley88aae3e2018-05-11 15:16:32 +09306inherit obmc-phosphor-systemd
7inherit allarch
8
9SRC_URI = "file://hb_settings"
10SYSTEMD_SERVICE_${PN} += "hostboot-settings.service"
11
12do_fetch[noexec] = "1"
13do_patch[noexec] = "1"
14do_configure[noexec] = "1"
15do_compile[noexec] = "1"
16
17do_install() {
18 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/hb_settings ${D}${bindir}
20}