blob: 675acfaf2609b0303b9a91d45962937b635141a6 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Performance analysis tools for Linux"
2DESCRIPTION = "Performance counters for Linux are a new kernel-based \
3subsystem that provide a framework for all things \
4performance analysis. It covers hardware level \
5(CPU/PMU, Performance Monitoring Unit) features \
6and software features (software counters, tracepoints) \
7as well."
Joel Stanleye252c312017-12-14 15:11:12 +10308HOMEPAGE = "https://perf.wiki.kernel.org/index.php/Main_Page"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010LICENSE = "GPL-2.0-only"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012
Andrew Geissler5082cc72023-09-11 08:41:39 -040013PACKAGECONFIG ??= "python tui libunwind libtraceevent"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
Andrew Geissler5082cc72023-09-11 08:41:39 -040015PACKAGECONFIG[perl] = ",NO_LIBPERL=1,perl"
16PACKAGECONFIG[python] = ",NO_LIBPYTHON=1,python3 python3-setuptools-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# gui support was added with kernel 3.6.35
18# since 3.10 libnewt was replaced by slang
19# to cover a wide range of kernel we add both dependencies
Joel Stanleye252c312017-12-14 15:11:12 +103020PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
21PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
22PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
Patrick Williams92b42cb2022-09-03 06:53:57 -050023PACKAGECONFIG[bfd] = ",NO_LIBBFD=1"
Joel Stanleye252c312017-12-14 15:11:12 +103024PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
25PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040026# libaudit support would need scripting to be enabled
27PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028PACKAGECONFIG[manpages] = ",,xmlto-native asciidoc-native"
Brad Bishop64c979e2019-11-04 13:55:29 -050029PACKAGECONFIG[cap] = ",,libcap"
Patrick Williamse760df82023-05-26 11:10:49 -050030PACKAGECONFIG[libtraceevent] = ",NO_LIBTRACEEVENT=1,libtraceevent"
Andrew Geisslerb7d28612020-07-24 16:15:54 -050031# Arm CoreSight
32PACKAGECONFIG[coresight] = "CORESIGHT=1,,opencsd"
Andrew Geissler5082cc72023-09-11 08:41:39 -040033PACKAGECONFIG[pfm4] = ",NO_LIBPFM4=1,libpfm4"
34PACKAGECONFIG[babeltrace] = ",NO_LIBBABELTRACE=1,babeltrace"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035
36# libunwind is not yet ported for some architectures
Patrick Williams213cb262021-08-07 19:21:33 -050037PACKAGECONFIG:remove:arc = "libunwind"
Patrick Williams213cb262021-08-07 19:21:33 -050038PACKAGECONFIG:remove:riscv32 = "libunwind"
Brad Bishop316dfdd2018-06-25 12:45:53 -040039
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040DEPENDS = " \
41 virtual/${MLPREFIX}libc \
42 ${MLPREFIX}elfutils \
43 ${MLPREFIX}binutils \
Brad Bishop316dfdd2018-06-25 12:45:53 -040044 bison-native flex-native xz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045"
46
47do_configure[depends] += "virtual/kernel:do_shared_workdir"
48
49PROVIDES = "virtual/perf"
50
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080051inherit linux-kernel-base kernel-arch manpages
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052
53# needed for building the tools/perf Python bindings
Andrew Geissler5082cc72023-09-11 08:41:39 -040054inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3targetconfig', '', d)}
Brad Bishop79641f22019-09-10 07:20:22 -040055inherit python3-dir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050056export PYTHON_SITEPACKAGES_DIR
57
58#kernel 3.1+ supports WERROR to disable warnings as errors
59export WERROR = "0"
60
Andrew Geissler82c905d2020-04-13 13:39:40 -050061do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062
63# needed for building the tools/perf Perl binding
Andrew Geissler5082cc72023-09-11 08:41:39 -040064include ${@bb.utils.contains('PACKAGECONFIG', 'perl', 'perf-perl.inc', '', d)}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065
66inherit kernelsrc
67
Brad Bishop316dfdd2018-06-25 12:45:53 -040068S = "${WORKDIR}/${BP}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050069SPDX_S = "${S}/tools/perf"
70
Patrick Williamsc124f4f2015-09-15 14:41:29 -050071# The LDFLAGS is required or some old kernels fails due missing
72# symbols and this is preferred than requiring patches to every old
73# supported kernel.
74LDFLAGS="-ldl -lutil"
75
76EXTRA_OEMAKE = '\
Andrew Geissler635e0e42020-08-21 15:58:33 -050077 V=1 \
Andrew Geissler5082cc72023-09-11 08:41:39 -040078 VF=1 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050079 -C ${S}/tools/perf \
80 O=${B} \
81 CROSS_COMPILE=${TARGET_PREFIX} \
82 ARCH=${ARCH} \
83 CC="${CC}" \
Andrew Geissler82c905d2020-04-13 13:39:40 -050084 CCLD="${CC}" \
85 LDSHARED="${CC} -shared" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050086 AR="${AR}" \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060087 LD="${LD}" \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050088 EXTRA_CFLAGS="-ldw -I${S}" \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050089 YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \
Joel Stanleye252c312017-12-14 15:11:12 +103090 EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050091 perfexecdir=${libexecdir} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080092 NO_GTK2=1 \
Joel Stanleye252c312017-12-14 15:11:12 +103093 ${PACKAGECONFIG_CONFARGS} \
Patrick Williamse760df82023-05-26 11:10:49 -050094 PKG_CONFIG=pkg-config \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080095 TMPDIR="${B}" \
Brad Bishop19323692019-04-05 15:28:33 -040096 LIBUNWIND_DIR=${STAGING_EXECPREFIXDIR} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050097'
98
99EXTRA_OEMAKE += "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500100 'DESTDIR=${D}' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500101 'prefix=${prefix}' \
102 'bindir=${bindir}' \
103 'sharedir=${datadir}' \
104 'sysconfdir=${sysconfdir}' \
105 'perfexecdir=${libexecdir}/perf-core' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500106 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
107 'sharedir=${@os.path.relpath(datadir, prefix)}' \
108 'mandir=${@os.path.relpath(mandir, prefix)}' \
109 'infodir=${@os.path.relpath(infodir, prefix)}' \
Andrew Geissler5082cc72023-09-11 08:41:39 -0400110 ${@bb.utils.contains('PACKAGECONFIG', 'python', 'PYTHON=python3 PYTHON_CONFIG=python3-config', '', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500111"
112
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700113# During do_configure, we might run a 'make clean'. That often breaks
114# when done in parallel, so disable parallelism for do_configure. Note
115# that it has to be done this way rather than by passing -j1, since
116# perf's build system by default ignores any -j argument, but does
117# honour a JOBS variable.
Patrick Williams213cb262021-08-07 19:21:33 -0500118EXTRA_OEMAKE:append:task-configure = " JOBS=1"
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700119
Brad Bishop316dfdd2018-06-25 12:45:53 -0400120PERF_SRC ?= "Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400121 tools/arch \
122 tools/build \
123 tools/include \
124 tools/lib \
125 tools/Makefile \
126 tools/perf \
127 tools/scripts \
Brad Bishop64c979e2019-11-04 13:55:29 -0500128 scripts/ \
129 arch/${ARCH}/Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400130"
131
Joel Stanleye252c312017-12-14 15:11:12 +1030132PERF_EXTRA_LDFLAGS = ""
133
Andrew Geissler595f6302022-01-24 19:11:47 +0000134# MIPS N32/N64
Patrick Williams213cb262021-08-07 19:21:33 -0500135PERF_EXTRA_LDFLAGS:mipsarchn32eb = "-m elf32btsmipn32"
136PERF_EXTRA_LDFLAGS:mipsarchn32el = "-m elf32ltsmipn32"
Andrew Geissler595f6302022-01-24 19:11:47 +0000137PERF_EXTRA_LDFLAGS:mipsarchn64eb = "-m elf64btsmip"
138PERF_EXTRA_LDFLAGS:mipsarchn64el = "-m elf64ltsmip"
Joel Stanleye252c312017-12-14 15:11:12 +1030139
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500140do_compile() {
141 # Linux kernel build system is expected to do the right thing
142 unset CFLAGS
Patrick Williamsb542dec2023-06-09 01:26:37 -0500143 test -e ${S}/tools/lib/traceevent/plugins/Makefile && \
144 sed -i -e 's|\$(libdir)/traceevent/plugins|\$(libdir)/traceevent_${KERNEL_VERSION}/plugins|g' ${S}/tools/lib/traceevent/plugins/Makefile
145 test -e ${S}/tools/perf/Makefile.config && \
146 sed -i -e 's|\$(libdir)/traceevent/plugins|\$(libdir)/traceevent_${KERNEL_VERSION}/plugins|g' ${S}/tools/perf/Makefile.config
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500147 oe_runmake all
148}
149
150do_install() {
151 # Linux kernel build system is expected to do the right thing
152 unset CFLAGS
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500153 oe_runmake install
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500154 # we are checking for this make target to be compatible with older perf versions
Andrew Geissler5082cc72023-09-11 08:41:39 -0400155 if ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)} && grep -q install-python_ext ${S}/tools/perf/Makefile*; then
Brad Bishop79641f22019-09-10 07:20:22 -0400156 oe_runmake DESTDIR=${D} install-python_ext
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500157 if [ -e ${D}${libdir}/python*/site-packages/perf-*/SOURCES.txt ]; then
158 sed -i -e 's#${WORKDIR}##g' ${D}${libdir}/python*/site-packages/perf-*/SOURCES.txt
159 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500160 fi
161}
162
Brad Bishop316dfdd2018-06-25 12:45:53 -0400163do_configure[prefuncs] += "copy_perf_source_from_kernel"
164python copy_perf_source_from_kernel() {
165 sources = (d.getVar("PERF_SRC") or "").split()
166 src_dir = d.getVar("STAGING_KERNEL_DIR")
167 dest_dir = d.getVar("S")
168 bb.utils.mkdirhier(dest_dir)
Andrew Geissler82c905d2020-04-13 13:39:40 -0500169 bb.utils.prunedir(dest_dir)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400170 for s in sources:
171 src = oe.path.join(src_dir, s)
172 dest = oe.path.join(dest_dir, s)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800173 if not os.path.exists(src):
174 bb.fatal("Path does not exist: %s. Maybe PERF_SRC does not match the kernel version." % src)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400175 if os.path.isdir(src):
176 oe.path.copyhardlinktree(src, dest)
177 else:
Brad Bishop64c979e2019-11-04 13:55:29 -0500178 src_path = os.path.dirname(s)
179 os.makedirs(os.path.join(dest_dir,src_path),exist_ok=True)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400180 bb.utils.copyfile(src, dest)
181}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500182
Patrick Williams213cb262021-08-07 19:21:33 -0500183do_configure:prepend () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500184 # If building a multlib based perf, the incorrect library path will be
185 # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit
William A. Kennington IIIac69b482021-06-02 12:28:27 -0700186 # build, with a 64 bit multilib, the arch won't match and the detection of a
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500187 # 64 bit build (and library) are not exected. To ensure that libraries are
188 # installed to the correct location, we can use the weak assignment in the
189 # config/Makefile.
190 #
191 # Also need to relocate .config-detected to $(OUTPUT)/config-detected
192 # for kernel sources that do not already do this
193 # as two builds (e.g. perf and lib32-perf from mutlilib can conflict
194 # with each other if its in the shared source directory
195 #
196 if [ -e "${S}/tools/perf/config/Makefile" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600197 perfconfig="${S}/tools/perf/config/Makefile"
198 fi
199 if [ -e "${S}/tools/perf/Makefile.config" ]; then
200 perfconfig="${S}/tools/perf/Makefile.config"
201 fi
202 if [ -n "${perfconfig}" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500203 # Match $(prefix)/$(lib) and $(prefix)/lib
204 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
205 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
206 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600207 ${perfconfig}
208 fi
209 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
210 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
211 # will use the relative path 'share/man', in the way it will resulting in
212 # incorrect installation for man pages.
213 if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then
214 sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500215 fi
216 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
217 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
218 ${S}/tools/perf/Makefile.perf
Patrick Williams92b42cb2022-09-03 06:53:57 -0500219 sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(PYTHON_SITEPACKAGES_DIR)' --root='\$(DESTDIR)',g" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500220 ${S}/tools/perf/Makefile.perf
Andrew Geissler635e0e42020-08-21 15:58:33 -0500221 # backport https://github.com/torvalds/linux/commit/e4ffd066ff440a57097e9140fa9e16ceef905de8
222 sed -i -e 's,\($(Q)$(SHELL) .$(arch_errno_tbl).\) $(CC) $(arch_errno_hdr_dir),\1 $(firstword $(CC)) $(arch_errno_hdr_dir),g' \
223 ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500224 fi
225 sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
Patrick Williamsd7e96312015-09-22 08:09:05 -0500226 ${S}/tools/perf/Makefile*
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500227
228 if [ -e "${S}/tools/build/Makefile.build" ]; then
229 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
230 ${S}/tools/build/Makefile.build
231 fi
232
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500233 # start reproducibility substitutions
234 if [ -e "${S}/tools/perf/Makefile.config" ]; then
235 # The following line in the Makefle:
236 # override PYTHON := $(call get-executable-or-default,PYTHON,$(PYTHON_AUTO))
237 # "PYTHON" / "PYTHON_AUTO" have the full path as part of the variable. We've
238 # ensure that the environment is setup and we do not need the full path to be
239 # captured, since the symbol gets built into the executable, making it not
240 # reproducible.
241 sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO))),g' \
242 ${S}/tools/perf/Makefile.config
Patrick Williamsdb4c27e2022-08-05 08:10:29 -0500243 # The same line is in older releases, but looking explicitly for Python 2
244 sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON2)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON2))),g' \
245 ${S}/tools/perf/Makefile.config
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500246
Andrew Geissler615f2f12022-07-15 14:00:58 -0500247 # likewise with this substitution. Kernels with commit 18f2967418d031a39
248 # [perf tools: Use Python devtools for version autodetection rather than runtime]
249 # need this substitution for reproducibility.
250 sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO))),$(notdir $(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO)))),g' \
251 ${S}/tools/perf/Makefile.config
252
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500253 # The following line:
254 # srcdir_SQ = $(patsubst %tools/perf,tools/perf,$(subst ','\'',$(srcdir))),
255 # Captures the full src path of perf, which of course makes it not
256 # reproducible. We really only need the relative location 'tools/perf', so we
257 # change the Makefile line to remove everything before 'tools/perf'
258 sed -i -e "s%srcdir_SQ = \$(subst ','\\\'',\$(srcdir))%srcdir_SQ = \$(patsubst \%tools/perf,tools/perf,\$(subst ','\\\'',\$(srcdir)))%g" \
259 ${S}/tools/perf/Makefile.config
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500260 # Avoid hardcoded path to python-native
261 sed -i -e 's#\(PYTHON_WORD := \)$(call shell-wordify,$(PYTHON))#\1 python3#g' \
262 ${S}/tools/perf/Makefile.config
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500263 fi
264 if [ -e "${S}/tools/perf/tests/Build" ]; then
265 # OUTPUT is the full path, we have python on the path so we remove it from the
266 # definition. This is captured in the perf binary, so breaks reproducibility
267 sed -i -e 's,PYTHONPATH="BUILD_STR($(OUTPUT)python)",PYTHONPATH="BUILD_STR(python)",g' \
268 ${S}/tools/perf/tests/Build
269 fi
270 if [ -e "${S}/tools/perf/util/Build" ]; then
271 # To avoid bison generating #ifdefs that have captured paths, we make sure
272 # all the calls have YFLAGS, which contains prefix mapping information.
273 sed -i -e 's,$(BISON),$(BISON) $(YFLAGS),g' ${S}/tools/perf/util/Build
274 fi
275 if [ -e "${S}/scripts/Makefile.host" ]; then
276 # To avoid yacc (bison) generating #ifdefs that have captured paths, we make sure
277 # all the calls have YFLAGS, which contains prefix mapping information.
278 sed -i -e 's,$(YACC),$(YACC) $(YFLAGS),g' ${S}/scripts/Makefile.host
279 fi
280 if [ -e "${S}/tools/perf/pmu-events/Build" ]; then
281 target='$(OUTPUT)pmu-events/pmu-events.c $(V)'
282 replacement1='$(OUTPUT)pmu-events/pmu-events.c $(V)\n'
283 replacement2='\t$(srctree)/sort-pmuevents.py $(OUTPUT)pmu-events/pmu-events.c $(OUTPUT)pmu-events/pmu-events.c.new\n'
284 replacement3='\tcp $(OUTPUT)pmu-events/pmu-events.c.new $(OUTPUT)pmu-events/pmu-events.c'
285 sed -i -e "s,$target,$replacement1$replacement2$replacement3,g" \
286 "${S}/tools/perf/pmu-events/Build"
287 fi
Patrick Williams864cc432023-02-09 14:54:44 -0600288 if [ -e "${S}/tools/perf/pmu-events/jevents.py" ]; then
289 sed -i -e "s#os.scandir(path)#sorted(os.scandir(path), key=lambda e: e.name)#g" \
290 "${S}/tools/perf/pmu-events/jevents.py"
291 fi
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500292 if [ -e "${S}/tools/perf/arch/arm64/Makefile" ]; then
293 sed -i 's,sysdef := $(srctree)/,sysdef := ,' ${S}/tools/perf/arch/arm64/Makefile
294 sed -i 's,$(incpath) $(sysdef),$(incpath) $(srctree)/$(sysdef) $(sysdef),' ${S}/tools/perf/arch/arm64/Makefile
295 fi
296 if [ -e "${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl" ]; then
297 if ! grep -q input_rel ${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl; then
298 sed -i 's,input=$4,input=$4\ninput_rel=$5,' ${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl
299 fi
300 sed -i 's,#include \\"\$input\\",#include \\"\$input_rel\\",' ${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl
301 fi
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500302 # end reproducibility substitutions
303
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500304 # We need to ensure the --sysroot option in CC is preserved
305 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
306 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf
307 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600308 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/perf/Makefile.perf
Patrick Williamse760df82023-05-26 11:10:49 -0500309 sed -i 's,PKG_CONFIG = $(CROSS_COMPILE)pkg-config,#PKG_CONFIG,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500310 fi
311 if [ -e "${S}/tools/lib/api/Makefile" ]; then
312 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
313 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600314 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/lib/api/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500315 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500316 if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
317 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
318 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
319 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500320 if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
321 sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
322 fi
323 if [ -e "${S}/tools/build/Makefile.feature" ]; then
324 sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature
325 fi
Andrew Geissler5082cc72023-09-11 08:41:39 -0400326 # The libperl feature check produces fatal warnings due to -Werror being
327 # used, silence enough errors that the check passes.
328 sed -i 's/\(FLAGS_PERL_EMBED=.*\)/\1 -Wno-error=unused-function -Wno-error=attributes/' ${S}/tools/build/feature/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500329
330 # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include
331 if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then
332 sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c
333 fi
334 if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then
335 sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c
336 sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c
337 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500338
339 # use /usr/bin/env instead of version specific python
Andrew Geissler82c905d2020-04-13 13:39:40 -0500340 for s in `find ${S}/tools/perf/ -name '*.py'` `find ${S}/scripts/ -name 'bpf_helpers_doc.py'`; do
341 sed -i -e "s,#!.*python.*,#!${USRBINPATH}/env python3," ${s}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500342 done
Brad Bishop19323692019-04-05 15:28:33 -0400343
344 # unistd.h can be out of sync between libc-headers and the captured version in the perf source
345 # so we copy it from the sysroot unistd.h to the perf unistd.h
Brad Bishopc342db32019-05-15 21:57:59 -0400346 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
Brad Bishop79641f22019-09-10 07:20:22 -0400347 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500348
349 # the fetcher is inhibited by the 'inherit kernelsrc', so we do a quick check and
350 # copy for a helper script we need
351 for p in $(echo ${FILESPATH} | tr ':' '\n'); do
352 if [ -e $p/sort-pmuevents.py ]; then
353 cp $p/sort-pmuevents.py ${S}
354 fi
355 done
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500356}
357
Patrick Williams213cb262021-08-07 19:21:33 -0500358python do_package:prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500359 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500360}
361
362PACKAGE_ARCH = "${MACHINE_ARCH}"
363
364
365PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
366
Patrick Williams213cb262021-08-07 19:21:33 -0500367RDEPENDS:${PN} += "elfutils bash"
368RDEPENDS:${PN}-archive =+ "bash"
369RDEPENDS:${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python', '', d)}"
370RDEPENDS:${PN}-perl =+ "bash perl perl-modules"
371RDEPENDS:${PN}-tests =+ "python3 bash"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500372
Andrew Geissler5082cc72023-09-11 08:41:39 -0400373RSUGGESTS:${PN} += "${PN}-archive ${PN}-tests \
374 ${@bb.utils.contains('PACKAGECONFIG', 'perl', '${PN}-perl', '', d)} \
375 ${@bb.utils.contains('PACKAGECONFIG', 'python', '${PN}-python', '', d)} \
376 "
Brad Bishop19323692019-04-05 15:28:33 -0400377FILES_SOLIBSDEV = ""
Patrick Williamsb542dec2023-06-09 01:26:37 -0500378FILES:${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent* ${libdir}/libperf-jvmti.so"
Patrick Williams213cb262021-08-07 19:21:33 -0500379FILES:${PN}-archive = "${libdir}/perf/perf-core/perf-archive"
380FILES:${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests"
381FILES:${PN}-python = " \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400382 ${PYTHON_SITEPACKAGES_DIR} \
383 ${libexecdir}/perf-core/scripts/python \
384 "
Patrick Williams213cb262021-08-07 19:21:33 -0500385FILES:${PN}-perl = "${libexecdir}/perf-core/scripts/perl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500386
Patrick Williams213cb262021-08-07 19:21:33 -0500387DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized"
Patrick Williams864cc432023-02-09 14:54:44 -0600388
389PACKAGESPLITFUNCS =+ "perf_fix_sources"
390
391perf_fix_sources () {
392 for f in util/parse-events-flex.h util/parse-events-flex.c util/pmu-flex.c \
Andrew Geissler8f840682023-07-21 09:09:43 -0500393 util/pmu-flex.h util/expr-flex.h util/expr-flex.c; do
Patrick Williams864cc432023-02-09 14:54:44 -0600394 f=${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/$f
395 if [ -e $f ]; then
396 sed -i -e 's#${S}/##g' $f
397 fi
398 done
399}