Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "File synchronization tool" |
| 2 | HOMEPAGE = "http://rsync.samba.org/" |
| 3 | BUGTRACKER = "http://rsync.samba.org/bugzilla.html" |
| 4 | SECTION = "console/network" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 5 | # GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0) |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 6 | # Includes opennsh and xxhash dynamic link exception |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 7 | LICENSE = "GPLv3+" |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=9e5a4f9b3a253d51520617aa54f8eb26" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | DEPENDS = "popt" |
| 11 | |
| 12 | SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \ |
| 13 | file://rsyncd.conf \ |
| 14 | file://makefile-no-rebuild.patch \ |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 15 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 17 | SRC_URI[sha256sum] = "becc3c504ceea499f4167a260040ccf4d9f2ef9499ad5683c179a697146ce50e" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | # -16548 required for v3.1.3pre1. Already in v3.1.3. |
| 20 | CVE_CHECK_WHITELIST += " CVE-2017-16548 " |
| 21 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 22 | inherit autotools-brokensep |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 24 | PACKAGECONFIG ??= "acl attr \ |
| 25 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ |
| 26 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 27 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 28 | PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl," |
| 29 | PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr," |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 31 | PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4" |
| 32 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| 33 | PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash" |
| 34 | PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | |
| 36 | # By default, if crosscompiling, rsync disables a number of |
| 37 | # capabilities, hardlinking symlinks and special files (i.e. devices) |
| 38 | CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes" |
| 39 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 40 | EXTRA_OEMAKE = 'STRIP=""' |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 41 | EXTRA_OECONF = "--disable-simd --disable-md2man --disable-asm" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 42 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 43 | # rsync 3.0 uses configure.sh instead of configure, and |
| 44 | # makefile checks the existence of configure.sh |
| 45 | do_configure_prepend () { |
| 46 | rm -f ${S}/configure ${S}/configure.sh |
| 47 | } |
| 48 | |
| 49 | do_configure_append () { |
| 50 | cp -f ${S}/configure ${S}/configure.sh |
| 51 | } |
| 52 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 53 | do_install_append() { |
| 54 | install -d ${D}${sysconfdir} |
| 55 | install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir} |
| 56 | } |
| 57 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 58 | BBCLASSEXTEND = "native" |