Vishwanatha Subbanna | fcf5076 | 2017-08-09 15:00:34 +0530 | [diff] [blame] | 1 | SUMMARY = "OpenPower OCC Control with MRW generated sensor IDs" |
| 2 | PR = "r1" |
Brad Bishop | 2879d32 | 2018-11-07 14:45:23 -0500 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
Brad Bishop | 1ebdb61 | 2019-09-13 12:18:25 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Vishwanatha Subbanna | fcf5076 | 2017-08-09 15:00:34 +0530 | [diff] [blame] | 5 | |
Vishwanatha Subbanna | fcf5076 | 2017-08-09 15:00:34 +0530 | [diff] [blame] | 6 | inherit openpower-occ-control |
Matt Spinler | 0a8ea63 | 2017-12-14 13:31:55 -0600 | [diff] [blame] | 7 | inherit mrw-xml |
Joseph Reynolds | 79809ea | 2021-02-26 15:37:31 -0600 | [diff] [blame] | 8 | inherit native |
Vishwanatha Subbanna | fcf5076 | 2017-08-09 15:00:34 +0530 | [diff] [blame] | 9 | |
| 10 | PROVIDES += "virtual/openpower-occ-control-config-native" |
| 11 | DEPENDS += "mrw-native mrw-perl-tools-native" |
| 12 | |
| 13 | # Generate a YAML files based on MRW input |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 14 | do_install:append() { |
Vishwanatha Subbanna | fcf5076 | 2017-08-09 15:00:34 +0530 | [diff] [blame] | 15 | install -d ${YAML_DEST}/ |
| 16 | ${STAGING_BINDIR_NATIVE}/perl-native/perl \ |
| 17 | ${STAGING_BINDIR_NATIVE}/gen_occ_map.pl \ |
Matt Spinler | 0a8ea63 | 2017-12-14 13:31:55 -0600 | [diff] [blame] | 18 | -i ${mrw_datadir}/${MRW_XML} \ |
Vishwanatha Subbanna | fcf5076 | 2017-08-09 15:00:34 +0530 | [diff] [blame] | 19 | -o ${YAML_DEST}/occ_sensor.yaml |
| 20 | } |