Patrick Williams | 314e833 | 2023-10-06 17:41:44 -0500 | [diff] [blame] | 1 | HOMEPAGE = "https://github.com/openbmc/pldm" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 4 | SRC_URI = "git://github.com/openbmc/pldm;branch=master;protocol=https" |
Andrew Geissler | 2ad1aff | 2023-10-25 02:20:29 -0500 | [diff] [blame^] | 5 | SRCREV = "4ddee3a0fda62e647cadafe07062d10e9db275b4" |
Patrick Williams | 314e833 | 2023-10-06 17:41:44 -0500 | [diff] [blame] | 6 | |
Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 7 | SUMMARY = "PLDM Stack" |
| 8 | DESCRIPTION = "Implementation of the PLDM specifications" |
Tom Joseph | f6785aa | 2021-06-15 07:12:34 -0700 | [diff] [blame] | 9 | DEPENDS += "function2" |
Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 10 | DEPENDS += "systemd" |
Matt Spinler | e2375b5 | 2020-01-20 14:09:47 -0600 | [diff] [blame] | 11 | DEPENDS += "sdeventplus" |
Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 12 | DEPENDS += "phosphor-dbus-interfaces" |
| 13 | DEPENDS += "nlohmann-json" |
Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 14 | DEPENDS += "cli11" |
Manojkiran Eda | c593475 | 2022-09-27 13:59:35 -0500 | [diff] [blame] | 15 | DEPENDS += "libpldm" |
Riya Dixit | 1b22133 | 2023-03-28 01:42:41 -0500 | [diff] [blame] | 16 | DEPENDS += "phosphor-logging" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 17 | PV = "1.0+git${SRCPV}" |
| 18 | PR = "r1" |
Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/git" |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 21 | SYSTEMD_SERVICE:${PN} += "pldmd.service" |
| 22 | SYSTEMD_SERVICE:${PN} += "pldmSoftPowerOff.service" |
Deepak Kodihalli | a748201 | 2020-06-22 05:25:35 -0500 | [diff] [blame] | 23 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 24 | inherit meson pkgconfig |
| 25 | inherit systemd |
| 26 | |
Andrew Jeffery | d828408 | 2023-10-22 21:43:37 +1030 | [diff] [blame] | 27 | PACKAGECONFIG[transport-mctp-demux] = "-Dtransport-implementation=mctp-demux" |
| 28 | PACKAGECONFIG[transport-af-mctp] = "-Dtransport-implementation=af-mctp" |
| 29 | PACKAGECONFIG ??= "" |
| 30 | PACKAGECONFIG:append:df-mctp = " transport-af-mctp" |
| 31 | |
Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 32 | EXTRA_OEMESON = " \ |
| 33 | -Dtests=disabled \ |
| 34 | -Doem-ibm=disabled \ |
| 35 | " |
Andrew Geissler | 0c3d0e2 | 2020-10-28 16:43:35 -0500 | [diff] [blame] | 36 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 37 | pkg_prerm:${PN} () { |
| 38 | LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service" |
| 39 | rm $LINK |
| 40 | LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service" |
| 41 | rm $LINK |
| 42 | } |
Andrew Geissler | 0c3d0e2 | 2020-10-28 16:43:35 -0500 | [diff] [blame] | 43 | # Install pldmSoftPowerOff.service in correct targets |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 44 | pkg_postinst:${PN} () { |
Manojkiran Eda | 842eb7f | 2021-09-15 18:47:42 +0530 | [diff] [blame] | 45 | mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants |
| 46 | LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service" |
Andrew Geissler | 0c3d0e2 | 2020-10-28 16:43:35 -0500 | [diff] [blame] | 47 | TARGET="../pldmSoftPowerOff.service" |
| 48 | ln -s $TARGET $LINK |
Manojkiran Eda | 842eb7f | 2021-09-15 18:47:42 +0530 | [diff] [blame] | 49 | mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants |
| 50 | LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service" |
Andrew Geissler | 0c3d0e2 | 2020-10-28 16:43:35 -0500 | [diff] [blame] | 51 | TARGET="../pldmSoftPowerOff.service" |
| 52 | ln -s $TARGET $LINK |
| 53 | } |