Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "World timezone definitions, modern and historical" |
| 2 | HOMEPAGE = "http://pythonhosted.org/pytz" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999" |
| 5 | |
| 6 | inherit pypi setuptools3 ptest |
| 7 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 8 | SRC_URI[sha256sum] = "2a29735ea9c18baf14b448846bde5a48030ed267578472d8955cd0e7443a9812" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 9 | |
| 10 | RDEPENDS:${PN}:class-target += "\ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 11 | python3-datetime \ |
| 12 | python3-doctest \ |
| 13 | python3-io \ |
| 14 | python3-pickle \ |
| 15 | python3-pprint \ |
| 16 | python3-threading \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | " |
| 18 | |
| 19 | BBCLASSEXTEND = "native nativesdk" |
| 20 | |
| 21 | SRC_URI += " \ |
| 22 | file://run-ptest \ |
| 23 | " |
| 24 | |
| 25 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 26 | python3-pytest \ |
| 27 | python3-unittest-automake-output \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 28 | " |
| 29 | |
| 30 | do_install_ptest() { |
| 31 | install -d ${D}${PTEST_PATH}/pytz |
| 32 | install -d ${D}${PTEST_PATH}/pytz/tests |
| 33 | cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/ |
| 34 | cp -f ${S}/README.rst ${D}${PTEST_PATH}/ |
| 35 | |
| 36 | } |