blob: 70df5ab87286275f20361cf0f1cb30d1f6b7384a [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Compressor/archiver for creating and modifying .zip files"
2HOMEPAGE = "http://www.info-zip.org"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "Info-ZIP's purpose is to provide free, portable, high-quality versions of the Zip and UnZip compressor-archiver utilities that are compatible with the DOS-based PKZIP by PKWARE, Inc."
Patrick Williamsc0f7c042017-02-23 20:41:17 -06004SECTION = "console/utils"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
Patrick Williamsc0f7c042017-02-23 20:41:17 -06009
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010S = "${WORKDIR}/zip30"
11
Patrick Williamsc0f7c042017-02-23 20:41:17 -060012SRC_URI = "${SOURCEFORGE_MIRROR}/infozip/Zip%203.x%20%28latest%29/3.0/zip30.tar.gz \
Brad Bishop15ae2502019-06-18 21:44:24 -040013 file://fix-security-format.patch \
14 file://10-remove-build-date.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://zipnote-crashes-with-segfault.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000016 file://0001-configure-use-correct-CPP.patch \
17 file://0002-configure-support-PIC-code-build.patch \
18 file://0001-configure-Use-CFLAGS-and-LDFLAGS-when-doing-link-tes.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050019 file://0001-configure-Specify-correct-function-signatures-and-de.patch \
20 file://0002-unix.c-Do-not-redefine-DIR-as-FILE.patch \
Patrick Williams520786c2023-06-25 16:20:36 -050021 file://0001-unix-configure-use-_Static_assert-to-do-correct-dete.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040022 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023UPSTREAM_VERSION_UNKNOWN = "1"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060024
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37"
26SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369"
27
Andrew Geissler8f840682023-07-21 09:09:43 -050028CVE_STATUS[CVE-2018-13410] = "disputed: Disputed and also Debian doesn't consider a vulnerability"
29CVE_STATUS[CVE-2018-13684] = "cpe-incorrect: Not for zip but for smart contract implementation for it"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060030
Patrick Williamsc124f4f2015-09-15 14:41:29 -050031# zip.inc sets CFLAGS, but what Makefile actually uses is
32# CFLAGS_NOOPT. It will also force -O3 optimization, overriding
33# whatever we set.
Patrick Williamsc0f7c042017-02-23 20:41:17 -060034EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
35 'CFLAGS=-I. -DUNIX ${CFLAGS}' \
36 'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}' \
37 'INSTALL=install' 'INSTALL_D=install -d' \
38 'BINFLAGS=0755'"
39
40do_compile() {
41 oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
42 sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
43 oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
44}
45
46do_install() {
47 oe_runmake -f unix/Makefile prefix=${D}${prefix} \
48 BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
49 install
50}
51
52BBCLASSEXTEND = "native"
53
54# exclude version 2.3.2 which triggers a false positive
55UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"