Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | GNOMEBASEBUILDCLASS = "meson" |
| 6 | |
| 7 | inherit gnomebase gsettings gettext gobject-introspection features_check upstream-version-is-even bash-completion |
| 8 | |
| 9 | REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam" |
| 10 | |
| 11 | DEPENDS = " \ |
| 12 | libxml2-native \ |
| 13 | sassc-native \ |
| 14 | gtk+3 \ |
| 15 | mutter \ |
| 16 | evolution-data-server \ |
| 17 | gcr \ |
| 18 | gjs \ |
| 19 | gnome-autoar \ |
| 20 | polkit \ |
| 21 | libcroco \ |
| 22 | startup-notification \ |
| 23 | ibus \ |
| 24 | gsettings-desktop-schemas \ |
| 25 | " |
| 26 | |
| 27 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 28 | |
| 29 | # gobject-introspection is mandatory and cannot be configured |
| 30 | REQUIRED_DISTRO_FEATURES += "gobject-introspection-data" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | UNKNOWN_CONFIGURE_WHITELIST:append = " introspection" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | |
| 33 | SRC_URI[archive.md5sum] = "4bd27c8a91d30fde78cb69b94677cf1f" |
| 34 | SRC_URI[archive.sha256sum] = "d296f318a74a6d7883358a6ce1c4d8808b7903dbbb4f9c61ab4230f18e6d7550" |
| 35 | |
| 36 | PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 37 | PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth" |
| 38 | PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false, networkmanager" |
| 39 | PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd" |
| 40 | |
| 41 | EXTRA_OEMESON = " \ |
| 42 | -Dman=false \ |
| 43 | " |
| 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 46 | # fix shebangs |
| 47 | for tool in `find ${D}${bindir} -name '*-tool'`; do |
| 48 | sed -i 's:#!${PYTHON}:#!${bindir}/${PYTHON_PN}:' $tool |
| 49 | done |
| 50 | } |
| 51 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 52 | GSETTINGS_PACKAGE = "${PN}-gsettings" |
| 53 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 54 | FILES:${PN} += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 55 | ${datadir}/dbus-1 \ |
| 56 | ${datadir}/gnome-control-center \ |
| 57 | ${datadir}/xdg-desktop-portal \ |
| 58 | ${systemd_user_unitdir} \ |
| 59 | " |
| 60 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 61 | RDEPENDS:${PN} += "gsettings-desktop-schemas gdm-base librsvg-gtk ${PN}-gsettings" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 62 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 63 | PACKAGES =+ "${PN}-tools ${PN}-gsettings" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 64 | FILES:${PN}-tools = "${bindir}/*-tool" |
| 65 | RDEPENDS:${PN}-tools = "python3-core" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 66 | |