blob: 413e6599db1d71fe07c84f764ec08b3fc2f2dda9 [file] [log] [blame]
Andrew Geissler3eeda902023-05-19 10:14:02 -05001SUMMARY="Pylint is a Python source code analyzer"
2HOMEPAGE= "http://www.pylint.org/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
5
6SRC_URI += " \
7 git://github.com/pylint-dev/pylint;branch=main;protocol=https \
8 file://run-ptest \
Andrew Geissler3eeda902023-05-19 10:14:02 -05009 "
Andrew Geissler20137392023-10-12 04:59:14 -060010SRCREV ?= "4a7ad5ea9f1c5a98ccf736578a00554be0da6dc7"
Andrew Geissler3eeda902023-05-19 10:14:02 -050011
12inherit python_setuptools_build_meta ptest
13
14RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
15 ${PYTHON_PN}-dill \
16 ${PYTHON_PN}-isort \
17 ${PYTHON_PN}-mccabe \
18 ${PYTHON_PN}-numbers \
19 ${PYTHON_PN}-platformdirs \
20 ${PYTHON_PN}-shell \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-pkgutil \
23 ${PYTHON_PN}-difflib \
24 ${PYTHON_PN}-netserver \
25 ${PYTHON_PN}-tomlkit \
26 "
27
28RDEPENDS:${PN}-ptest += " \
29 ${PYTHON_PN}-core \
30 ${PYTHON_PN}-git \
31 ${PYTHON_PN}-py \
32 ${PYTHON_PN}-pytest \
33 ${PYTHON_PN}-pytest-benchmark \
34 ${PYTHON_PN}-pytest-runner \
35 ${PYTHON_PN}-pytest-timeout \
36 ${PYTHON_PN}-pytest-xdist \
37 ${PYTHON_PN}-requests \
38 ${PYTHON_PN}-statistics \
39 ${PYTHON_PN}-tomllib \
40 ${PYTHON_PN}-typing-extensions \
41 "
42
43S = "${WORKDIR}/git"
44
45do_install_ptest() {
46 install -d ${D}${PTEST_PATH}/tests
47 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
Andrew Geissler20137392023-10-12 04:59:14 -060048 install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
Andrew Geissler3eeda902023-05-19 10:14:02 -050049 sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
50}