blob: 59a00be15446fc5982e914c5360975dcfca6926d [file] [log] [blame]
Patrick Williams39653562024-03-01 08:54:02 -06001DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
Patrick Williams03514f12024-04-05 07:04:11 -05006SRC_URI[sha256sum] = "c2313d059a9f4d1221243fcda64fb8ae11603c1745e92d57c4071aad04336696"
Patrick Williams39653562024-03-01 08:54:02 -06007
8inherit python_poetry_core pypi
9
Patrick Williams39653562024-03-01 08:54:02 -060010RDEPENDS:${PN} += " \
11 python3-dateutil \
12 python3-json \
13 python3-jsonschema \
14 python3-requests \
15 python3-six \
16 python3-deprecated \
17 python3-wrapt \
18"
19
20# Fixes: python3-pymisp requires /bin/bash, but no
21# providers found in RDEPENDS:python3-pymisp? [file-rdep]
22RDEPENDS:${PN} += "bash"