Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/" |
| 3 | LICENSE = "LGPL-2.1+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36" |
| 5 | SECTION = "net" |
| 6 | |
| 7 | DEPENDS = "file" |
| 8 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 9 | SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz" |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 10 | SRC_URI[md5sum] = "2a286193af88ab2ae3149748d4b46187" |
| 11 | SRC_URI[sha256sum] = "0ae825f8e0d7f41201fd44a0df1cf454c1cb0bc50fe9d59c26552260264c2ff8" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | inherit autotools lib_package pkgconfig gettext |
| 14 | |
| 15 | CFLAGS += "-pthread -D_REENTRANT" |
| 16 | |
| 17 | EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../" |
| 18 | |
| 19 | PACKAGECONFIG ?= "curl https" |
| 20 | PACKAGECONFIG_append_class-target = "\ |
| 21 | ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \ |
| 22 | " |
| 23 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," |
| 24 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," |
| 25 | PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls," |
| 26 | |
| 27 | do_compile_append() { |
| 28 | sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc |
| 29 | } |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |