Andrew Geissler | 3e34fba | 2021-03-05 15:21:55 -0600 | [diff] [blame^] | 1 | SUMMARY = "CircuitPython APIs for non-CircuitPython versions of Python such as CPython on Linux and MicroPython." |
| 2 | HOMEPAGE = "https://github.com/adafruit/Adafruit_Blinka" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=660e614bc7efb0697cc793d8a22a55c2" |
| 5 | |
| 6 | SRC_URI = "git://github.com/adafruit/Adafruit_Blinka.git" |
| 7 | SRCREV = "dc688f354fe779c9267c208b99f310af87e79272" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit setuptools3 |
| 12 | |
| 13 | DEPENDS += "python3-setuptools-scm-native" |
| 14 | |
| 15 | do_install_append() { |
| 16 | # it ships ./bcm283x/pulseio/libgpiod_pulsein which is a prebuilt |
| 17 | # 32bit binary therefore we should make this specific to 32bit rpi machines (based on bcm283x) only |
| 18 | if [ ${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '1', '0', d)} = "0" ]; then |
| 19 | rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/adafruit_blinka/microcontroller/bcm283x |
| 20 | fi |
| 21 | } |
| 22 | |
| 23 | RDEPENDS_${PN} += " \ |
| 24 | libgpiod \ |
| 25 | python3-adafruit-platformdetect \ |
| 26 | python3-adafruit-pureio \ |
| 27 | python3-core \ |
| 28 | " |
| 29 | |
| 30 | RDEPENDS_${PN}_append_rpi = " rpi-gpio" |