blob: 837edf7df7237174c13a71f71ae2e1c646641ca0 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python front end for libmagic"
2DESCRIPTION = "This library is a Python ctypes interface to libmagic."
3HOMEPAGE = "https://darwinsys.com/file/"
4LICENSE = "BSD-2-Clause"
5SECTION = "devel/python"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0e949c0b3fb4fd86232f00c6ee0bdef3"
7
8SRC_URI[sha256sum] = "a91d1483117f7ed48cd0238ad9be36b04824d57e9c38ea7523113989e81b9c53"
9
10PYPI_PACKAGE="file-magic"
11
12inherit pypi setuptools3
13
14RDEPENDS:${PN} += " \
15 file \
16 ${PYTHON_PN}-core \
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-threading \
19"
20
21BBCLASSEXTEND = "native nativesdk"