Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A New System Troubleshooting Tool Built for the Way You Work" |
| 2 | DESCRIPTION = "Sysdig is open source, system-level exploration: capture \ |
| 3 | system state and activity from a running Linux instance, then save, \ |
| 4 | filter and analyze." |
| 5 | HOMEPAGE = "http://www.sysdig.org/" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | LICENSE = "Apache-2.0 & (MIT | GPL-2.0)" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=f8fee3d59797546cffab04f3b88b2d44" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | |
| 9 | inherit cmake pkgconfig |
| 10 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | #OECMAKE_GENERATOR = "Unix Makefiles" |
| 12 | JIT ?= "jit" |
| 13 | JIT_mipsarchn32 = "" |
| 14 | JIT_mipsarchn64 = "" |
| 15 | JIT_riscv64 = "" |
| 16 | JIT_riscv32 = "" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 17 | JIT_powerpc = "" |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 18 | JIT_powerpc64le = "" |
| 19 | JIT_powerpc64 = "" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 20 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 21 | DEPENDS += "libb64 lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp tbb jq openssl elfutils protobuf protobuf-native jq-native" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 22 | RDEPENDS_${PN} = "bash" |
| 23 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | SRC_URI = "git://github.com/draios/sysdig.git;branch=dev \ |
| 25 | file://0001-fix-build-with-LuaJIT-2.1-betas.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | file://aarch64.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 27 | " |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 28 | SRCREV = "67833b2aca06bd9d11cff7cb29f04fbf4ef96cad" |
| 29 | PV = "0.27.1" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 30 | |
| 31 | S = "${WORKDIR}/git" |
| 32 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | EXTRA_OECMAKE = "\ |
| 34 | -DBUILD_DRIVER=OFF \ |
| 35 | -DUSE_BUNDLED_DEPS=OFF \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 36 | -DCREATE_TEST_TARGETS=OFF \ |
| 37 | -DDIR_ETC=${sysconfdir} \ |
| 38 | -DLUA_INCLUDE_DIR=${STAGING_INCDIR}/luajit-2.1 \ |
| 39 | -DLUA_LIBRARY=libluajit-5.1.so \ |
| 40 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 41 | |
| 42 | FILES_${PN} += " \ |
| 43 | ${DIR_ETC}/* \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 44 | ${datadir}/zsh/* \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 45 | ${prefix}/src/* \ |
| 46 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 47 | # Use getaddrinfo_a is a GNU extension in libsinsp |
| 48 | # It should be fixed in sysdig, until then disable |
| 49 | # on musl |
| 50 | # Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it |
| 51 | COMPATIBLE_HOST_libc-musl = "null" |
| 52 | COMPATIBLE_HOST_mips = "null" |
| 53 | COMPATIBLE_HOST_riscv64 = "null" |
| 54 | COMPATIBLE_HOST_riscv32 = "null" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 55 | COMPATIBLE_HOST_powerpc = "null" |