blob: c3c26dda38dde6cd206da46bda5d60d4dfa93259 [file] [log] [blame]
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05001DESCRIPTION = "The tools for verifying whether a certificate is valid for the intended purposes."
2HOMEPAGE = "https://pypi.org/project/service-identity"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05003
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8a0f079f4e6a215d6bd6f9d97cab4d5f"
6
7SRC_URI[md5sum] = "5e5c195d8fcedc72f9068be2ad9b5a13"
8SRC_URI[sha256sum] = "6e6c6086ca271dc11b033d17c3a8bea9f24ebff920c587da090afc9519419d34"
9
10inherit pypi setuptools3 ptest
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
Patrick Williamsb542dec2023-06-09 01:26:37 -050016RDEPENDS:${PN} += " \
17 python3-attr \
18 python3-cryptography \
19 python3-pyasn1-modules \
20"
21
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050022RDEPENDS:${PN}-ptest += " \
23 ${PYTHON_PN}-pytest \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29 cp -rf ${S}/setup.py ${D}${PTEST_PATH}
30}