blob: 94f2e37a89a4177d69a6151031ec209d555be319 [file] [log] [blame]
Andrew Geissler220dafd2023-10-04 10:18:08 -05001SUMMARY = "APIFlask is a lightweight Python web API framework based on Flask and marshmallow-code projects."
2HOMEPAGE = "https://github.com/apiflask/apiflask"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5f89d1b0dec37448d4f4163dc3c40e64"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "APIFlask"
9
Patrick Williams03514f12024-04-05 07:04:11 -050010SRC_URI[sha256sum] = "88db5a539cc155e35d9636d99b434d00ca6c0b23e7c87c8321ec9dc980535366"
Andrew Geissler220dafd2023-10-04 10:18:08 -050011
12RDEPENDS:${PN} += "\
13 python3-flask \
14 python3-flask-marshmallow \
15 python3-webargs \
16 python3-flask-httpauth \
17 python3-apispec \
18 "