Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Python utilities for working with Ethereum ABI definitions, especially encoding and decoding." |
| 2 | HOMEPAGE = "https://github.com/ethereum/eth-abi" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=731f4de9c79bfeba6d8d55f83d0d2423" |
| 6 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "e9425110c6120c585c9f0db2e8a33d76c4b886b148a65e68fc0035d3917a3b9c" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 8 | |
| 9 | PYPI_PACKAGE = "eth_abi" |
| 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | RDEPENDS:${PN} += " \ |
| 14 | python3-eth-typing \ |
| 15 | python3-eth-utils \ |
| 16 | python3-parsimonious \ |
| 17 | python3-setuptools \ |
| 18 | " |