Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "MQTT version 3.1/3.1.1 client library" |
| 2 | LICENSE = "EPL-1.0 | EDL-1.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e5f264c6988aec56808a3a11e77b913 \ |
| 4 | file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \ |
| 5 | " |
| 6 | SRCNAME = "paho-mqtt" |
| 7 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 8 | inherit pypi python_hatchling python_setuptools_build_meta |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 9 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "13b205f29251e4f2c66a6c923c31fc4fd780561e03b2d775cff8e4f2915cf947" |
| 11 | |
| 12 | PYPI_SRC_URI = "https://files.pythonhosted.org/packages/73/b7/a4df0f93bbdae237e16ba402752151eceee576cbe80c235a2475fbf81eea/paho_mqtt-${PV}.tar.gz" |
| 13 | |
| 14 | S = "${WORKDIR}/paho_mqtt-${PV}" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 15 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 16 | DEPENDS += "python3-pytest-runner-native" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 17 | |
| 18 | do_install:append() { |
| 19 | install -d -m0755 ${D}${datadir}/${BPN}/examples |
| 20 | cp --preserve=mode,timestamps -R ${S}/examples/* ${D}${datadir}/${BPN}/examples |
| 21 | } |
| 22 | |
| 23 | PACKAGES =+ "${PN}-examples" |
| 24 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 25 | RDEPENDS:${PN}-examples += "${PN} python3-core" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 26 | |
| 27 | FILES:${PN}-examples = "${datadir}/${BPN}/examples" |
| 28 | |
| 29 | RDEPENDS:${PN} = "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 30 | python3-io \ |
| 31 | python3-logging \ |
| 32 | python3-math \ |
| 33 | python3-netclient \ |
| 34 | python3-threading \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 35 | " |
| 36 | |
| 37 | BBCLASSEXTEND = "native nativesdk" |