blob: d6706d3e7a3e2e51f1b89e0f5fadf363c18781ca [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "open-source formatting library for C++"
2DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams."
3HOMEPAGE = "https://fmt.dev"
4LICENSE = "MIT"
Patrick Williamse760df82023-05-26 11:10:49 -05005LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=b9257785fc4f3803a4b71b76c1412729"
Andrew Geissler595f6302022-01-24 19:11:47 +00006
7SRC_URI = "git://github.com/fmtlib/fmt;branch=master;protocol=https"
Andrew Geissler5082cc72023-09-11 08:41:39 -04008SRCREV = "f5e54359df4c26b6230fc61d38aa294581393084"
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10S = "${WORKDIR}/git"
11
12inherit cmake
13inherit ptest
14
15EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"
16
17BBCLASSEXTEND = "native nativesdk"