blob: 57b31a78d9f5db23a585c2235cc66864330d2a7d [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Reparent a running program to a new terminal"
2DESCRIPTION = "reptyr is a utility for taking an existing running program and \
3attaching it to a new terminal. Started a long-running process over ssh, but \
4have to leave and don't want to interrupt it? Just start a screen, use reptyr \
5to grab it, and then kill the ssh session and head on home."
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=25a0555028c71837623fa6dfa4cc45c0"
8
9SRC_URI = "git://github.com/nelhage/reptyr.git;protocol=https;branch=master"
10SRCREV = "1238097fc2cd15db058d2185cc4985daa87bcd41"
11
12S = "${WORKDIR}/git"
13
14inherit bash-completion github-releases manpages pkgconfig
15
16GITHUB_BASE_URI = "https://github.com/nelhage/${BPN}/releases/"
17
18PACKAGECONFIG ?= ""
19PACKAGECONFIG[manpages] = ""
20
21EXTRA_OEMAKE = "'BINDIR=${bindir}' 'MANDIR=${mandir}' 'PKG_CONFIG=${STAGING_BINDIR_NATIVE}/pkg-config'"
22
23do_compile () {
24 oe_runmake
25}
26
27do_install () {
28 oe_runmake install 'DESTDIR=${D}'
29}