Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Multiplexing terminal manager" |
| 2 | DESCRIPTION = "Screen is a full-screen window manager \ |
| 3 | that multiplexes a physical terminal between several \ |
| 4 | processes, typically interactive shells." |
| 5 | HOMEPAGE = "http://www.gnu.org/software/screen/" |
| 6 | BUGTRACKER = "https://savannah.gnu.org/bugs/?func=additem&group=screen" |
| 7 | |
| 8 | SECTION = "console/utils" |
| 9 | |
| 10 | LICENSE = "GPLv3+" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 12 | file://screen.h;endline=26;md5=3971142989289a8198a544220703c2bf" |
| 13 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | DEPENDS = "ncurses virtual/crypt \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
| 16 | RDEPENDS_${PN} = "base-files" |
| 17 | |
| 18 | SRC_URI = "${GNU_MIRROR}/screen/screen-${PV}.tar.gz \ |
| 19 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'file://screen.pam', '', d)} \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 20 | file://0002-comm.h-now-depends-on-term.h.patch \ |
| 21 | file://0001-fix-for-multijob-build.patch \ |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 22 | file://0001-Remove-more-compatibility-stuff.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 23 | " |
| 24 | |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 25 | SRC_URI[md5sum] = "b8971ebd68d046f2814d1040cb8e6641" |
| 26 | SRC_URI[sha256sum] = "da775328fa783bd2a787d722014dbd99c6093effc11f337827604c2efc5d20c1" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 27 | |
| 28 | inherit autotools texinfo |
| 29 | |
| 30 | PACKAGECONFIG ??= "" |
| 31 | PACKAGECONFIG[utempter] = "ac_cv_header_utempter_h=yes,ac_cv_header_utempter_h=no,libutempter," |
| 32 | |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 33 | EXTRA_OECONF = "--with-pty-mode=0620 --with-pty-group=5 --with-sys-screenrc=${sysconfdir}/screenrc \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 34 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)}" |
| 35 | |
| 36 | do_install_append () { |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 37 | install -D -m 644 ${S}/etc/etcscreenrc ${D}/${sysconfdir}/screenrc |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 38 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then |
| 39 | install -D -m 644 ${WORKDIR}/screen.pam ${D}/${sysconfdir}/pam.d/screen |
| 40 | fi |
| 41 | } |
| 42 | |
| 43 | pkg_postinst_${PN} () { |
| 44 | grep -q "^${bindir}/screen$" $D${sysconfdir}/shells || echo ${bindir}/screen >> $D${sysconfdir}/shells |
| 45 | } |
| 46 | |
| 47 | pkg_postrm_${PN} () { |
| 48 | printf "$(grep -v "^${bindir}/screen$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells |
| 49 | } |