Brad Bishop | 93c3acf | 2019-10-29 09:48:15 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Gstreamer Daemon" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 2 | SUMMARY = "GStreamer framework for controlling audio and video streaming using TCP connection messages" |
| 3 | HOMEPAGE = "https://developer.ridgerun.com/wiki/index.php?title=Gstd-1.0" |
| 4 | SECTION = "multimedia" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 5 | LICENSE = "LGPL-2.1-or-later" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=c71b653a0f608a58cdc5693ae57126bc" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 7 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 8 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gstreamer1.0-rtsp-server json-glib libdaemon libsoup-2.4 jansson" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | |
| 10 | SRCBRANCH ?= "master" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 11 | SRCREV = "a011affa67f240cbc7aaff5b00fdfd6124bdaece" |
| 12 | SRC_URI = "git://git@github.com/RidgeRun/gstd-1.x.git;protocol=https;branch=${SRCBRANCH}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | S = "${WORKDIR}/git" |
| 14 | |
Brad Bishop | 93c3acf | 2019-10-29 09:48:15 -0400 | [diff] [blame] | 15 | # Remove the +really when upstream version is > 1.0 |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 16 | PV = "1.0+really0.15.0" |
Brad Bishop | 93c3acf | 2019-10-29 09:48:15 -0400 | [diff] [blame] | 17 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 18 | GTKDOC_MESON_OPTION = "enable-gtk-doc" |
| 19 | |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 20 | inherit meson pkgconfig gettext gtk-doc python3native python3-dir python3targetconfig |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | do_install:append() { |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 23 | rmdir ${D}${exec_prefix}${localstatedir}/run/${BPN} ${D}${exec_prefix}${localstatedir}/run \ |
| 24 | ${D}${exec_prefix}${localstatedir}/log/${BPN} ${D}${exec_prefix}${localstatedir}/log \ |
| 25 | ${D}${exec_prefix}${localstatedir} |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 26 | rm -f ${D}${bindir}/gst-client ${D}${bindir}/gstd-client |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 27 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 28 | install -d ${D}${sysconfdir}/tmpfiles.d |
| 29 | echo "d /run/${BPN} - - - -" \ |
| 30 | > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 31 | echo "d ${localstatedir}/log/${BPN} 0755 root root -" \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 32 | >> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf |
| 33 | fi |
| 34 | ln -sf gst-client-1.0 ${D}${bindir}/gst-client |
| 35 | ln -sf gst-client-1.0 ${D}${bindir}/gstd-client |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 36 | } |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 37 | PACKAGES =+ "${PN}-python" |
| 38 | |
| 39 | FILES:${PN} += "${systemd_user_unitdir}" |
| 40 | FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*" |