blob: 208ac3c58be9ce6aaacb64d8626842eaed2dc1ec [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Tool to access UFS (Universal Flash Storage) devices"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
5PV = "1.3+git${SRCPV}"
6
7BRANCH ?= "dev"
8
9SRCREV = "8b00e33003b57d7071943f63863fcf8cc48d5be9"
10
11SRC_URI = "git://github.com/westerndigitalcorporation/ufs-tool.git;protocol=git;branch=${BRANCH}"
12
13S = "${WORKDIR}/git"
14
Brad Bishop90ca7472019-08-20 09:15:15 -040015EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}" CFLAGS="${CFLAGS}""
Brad Bishop26bdd442019-08-16 17:08:17 -040016
Brad Bishop90ca7472019-08-20 09:15:15 -040017do_configure() {
18 sed -i -e "s|-static$||g" ${S}/Makefile
19}
Brad Bishop26bdd442019-08-16 17:08:17 -040020do_install() {
21 install -d ${D}${bindir}/
22 install -c -m 755 ${S}/ufs-tool ${D}${bindir}/
23}