Jorge Cisneros | 8a445a0 | 2020-09-03 21:09:03 +0000 | [diff] [blame] | 1 | LICENSE = "CLOSED" |
| 2 | LIC_FILES_CHKSUM = "" |
| 3 | |
| 4 | |
| 5 | BBRANCH = "master" |
Patrick Williams | bb99d22 | 2022-01-24 15:55:09 -0600 | [diff] [blame] | 6 | SRC_URI = "git://github.com/HewlettPackard/gxp-bootblock.git;branch=${BBRANCH};protocol=https" |
Mike Garrett | 4eb108b | 2021-08-27 15:51:09 -0500 | [diff] [blame] | 7 | SRCREV = "bab416f8ca8c8465d308cfeb7f8d5abc21ba343b" |
Jorge Cisneros | 8a445a0 | 2020-09-03 21:09:03 +0000 | [diff] [blame] | 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit deploy |
| 11 | |
| 12 | do_deploy () { |
| 13 | install -d ${DEPLOYDIR} |
Mike Garrett | 4eb108b | 2021-08-27 15:51:09 -0500 | [diff] [blame] | 14 | install -m 644 gxp-bootblock.bin ${DEPLOYDIR}/gxp-bootblock.bin |
Jorge Cisneros | 8a445a0 | 2020-09-03 21:09:03 +0000 | [diff] [blame] | 15 | |
| 16 | } |
| 17 | |
| 18 | addtask deploy before do_build after do_compile |
| 19 | |