blob: 139aa479b214f00427efa4764bd3501a5f9d68b1 [file] [log] [blame]
Andrew Geissler87f5cff2022-09-30 13:13:31 -05001# SPDX-FileCopyrightText: Huawei Inc.
2# SPDX-License-Identifier: MIT
3
Andrew Geissler3eeda902023-05-19 10:14:02 -05004SRC_URI = "git://git.ostc-eu.org/rzr/dialog-lvgl;destsuffix=${S};protocol=https;nobranch=1 \
5 file://0001-wayland-Switch-to-custom-timer-tick.patch \
6 file://0002-wayland-Fix-callback-data-type.patch \
7 "
8SRCREV = "cdf8d38acca87e871c3a488fd07f1e4779590f8e"
Andrew Geissler87f5cff2022-09-30 13:13:31 -05009
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=8ce0a84e5276f01364119c873b712c4f"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012
13DEPENDS += "lvgl"
14DEPENDS += "lv-drivers"
15
16SUMMARY = "Basic UI utility to be used in scripts"
17DESCRIPTION = "Inspired by ncurses' dialog, implemented using LVGL"
18HOMEPAGE = "https://git.ostc-eu.org/rzr/dialog-lvgl/-/wikis/"
19
20REQUIRED_DISTRO_FEATURES = "wayland"
21
22inherit pkgconfig
23inherit features_check
24
25EXTRA_OEMAKE += "sysroot=${RECIPE_SYSROOT}"
26EXTRA_OEMAKE += "DESTDIR=${D}"
27EXTRA_OEMAKE += "lvgl_driver=wayland"
28
29do_install() {
30 oe_runmake install
31}