blob: 9b36b57cb701578973384baf40f04a86ec2bf92b [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A top utility for I/O"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-or-later"
Patrick Williams73bd93f2024-02-20 08:07:48 -06003LIC_FILES_CHKSUM = "file://LICENSE;md5=686f457fedcecd9b92d69e625291ffa2"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004
5DEPENDS = "ncurses"
6
Patrick Williamsda295312023-12-05 16:48:56 -06007SRC_URI = "git://github.com/Tomas-M/iotop.git;branch=master;protocol=https"
Patrick Williams73bd93f2024-02-20 08:07:48 -06008SRCREV = "b15743b04bb04ff1fc6e197d21ba30365349edcb"
Patrick Williamsda295312023-12-05 16:48:56 -06009
10S = "${WORKDIR}/git"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011
12inherit pkgconfig
13
14EXTRA_OEMAKE = "V=1 STRIP=true"
15# Fixes llvm-bc70b5.o: can't link soft-float modules with double-float modules
16EXTRA_OEMAKE:append:toolchain-clang:riscv64 = " NO_FLTO=1"
17EXTRA_OEMAKE:append:toolchain-clang:riscv32 = " NO_FLTO=1"
18
19# Workaround BFD linker crash with clang on arm
20# revisit when upgrading binutils and see if its fixed
21LDFLAGS:append:toolchain-clang:arm = " -fuse-ld=lld"
22
23do_install() {
24 oe_runmake install DESTDIR=${D}
25}