Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \ |
| 2 | Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \ |
| 3 | Contributors." |
| 4 | HOMEPAGE = "https://pillow.readthedocs.io" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b22dc6b663b9175820e5e03337c7596b" |
| 7 | |
Patrick Williams | f52e3dd | 2024-01-26 13:04:43 -0600 | [diff] [blame] | 8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 9 | file://0001-support-cross-compiling.patch \ |
| 10 | file://0001-explicitly-set-compile-options.patch \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | SRCREV ?= "da59ad000d1405eaecd557175e29083a87d19f7c" |
| 14 | |
| 15 | inherit setuptools3 ptest |
| 16 | |
| 17 | PIP_INSTALL_PACKAGE = "Pillow" |
| 18 | PIP_INSTALL_DIST_PATH = "${S}/dist" |
| 19 | |
| 20 | DEPENDS += " \ |
| 21 | zlib \ |
| 22 | jpeg \ |
| 23 | tiff \ |
| 24 | freetype \ |
| 25 | lcms \ |
| 26 | openjpeg \ |
| 27 | " |
| 28 | |
| 29 | RDEPENDS:${PN} += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 30 | python3-misc \ |
| 31 | python3-logging \ |
| 32 | python3-numbers \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 33 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb', '', d)} \ |
| 34 | " |
| 35 | |
| 36 | RDEPENDS:${PN}-ptest += " \ |
| 37 | bash \ |
| 38 | ghostscript \ |
| 39 | jpeg-tools \ |
| 40 | libwebp \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 41 | python3-core \ |
| 42 | python3-image \ |
| 43 | python3-mmap \ |
| 44 | python3-pytest \ |
| 45 | python3-pytest-timeout \ |
| 46 | python3-resource \ |
| 47 | python3-unittest-automake-output \ |
| 48 | python3-unixadmin\ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 49 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'tk', '', d)} \ |
| 50 | " |
| 51 | |
| 52 | CVE_PRODUCT = "pillow" |
| 53 | |
| 54 | S = "${WORKDIR}/git" |
| 55 | |
| 56 | RPROVIDES:${PN} += "python3-imaging" |
| 57 | |
| 58 | do_install_ptest() { |
| 59 | install -d ${D}${PTEST_PATH}/Tests |
| 60 | cp -rf ${S}/Tests ${D}${PTEST_PATH}/ |
| 61 | } |
| 62 | |
| 63 | BBCLASSEXTEND = "native" |