blob: 8e023c7dfb84ec270a020cab6a8631a460aab706 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3DESCRIPTION = "Python is a programming language that lets you work more quickly and integrate your systems more effectively."
4LICENSE = "PSF-2.0"
5SECTION = "devel/python"
6
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06007LIC_FILES_CHKSUM = "file://LICENSE;md5=fcf6b249c2641540219a727f35d8d2c2"
Andrew Geissler517393d2023-01-13 08:55:19 -06008
9SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
10 file://run-ptest \
11 file://create_manifest3.py \
12 file://get_module_deps3.py \
13 file://python3-manifest.json \
14 file://check_build_completeness.py \
15 file://reformat_sysconfig.py \
16 file://cgi_py.patch \
17 file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \
18 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \
19 file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \
20 file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \
21 file://crosspythonpath.patch \
22 file://0001-test_locale.py-correct-the-test-output-format.patch \
23 file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \
24 file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \
25 file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \
26 file://0001-Skip-failing-tests-due-to-load-variability-on-YP-AB.patch \
27 file://0001-test_ctypes.test_find-skip-without-tools-sdk.patch \
28 file://makerace.patch \
29 file://0001-sysconfig.py-use-platlibdir-also-for-purelib.patch \
30 file://0001-Lib-pty.py-handle-stdin-I-O-errors-same-way-as-maste.patch \
31 file://0001-setup.py-Do-not-detect-multiarch-paths-when-cross-co.patch \
32 file://deterministic_imports.patch \
33 file://0001-Avoid-shebang-overflow-on-python-config.py.patch \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050034 file://0001-Update-test_sysconfig-for-posix_user-purelib.patch \
Andrew Geissler220dafd2023-10-04 10:18:08 -050035 file://0001-skip-no_stdout_fileno-test-due-to-load-variability.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060036 "
37
38SRC_URI:append:class-native = " \
39 file://0001-Lib-sysconfig.py-use-prefix-value-from-build-configu.patch \
40 file://12-distutils-prefix-is-inside-staging-area.patch \
41 file://0001-Don-t-search-system-for-headers-libraries.patch \
42 "
Andrew Geissler5082cc72023-09-11 08:41:39 -040043SRC_URI[sha256sum] = "85cd12e9cf1d6d5a45f17f7afe1cebe7ee628d3282281c492e86adf636defa3f"
Andrew Geissler517393d2023-01-13 08:55:19 -060044
45# exclude pre-releases for both python 2.x and 3.x
46UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
47UPSTREAM_CHECK_URI = "https://www.python.org/downloads/source/"
48
Andrew Geissler220dafd2023-10-04 10:18:08 -050049CVE_PRODUCT = "python cpython"
Andrew Geissler517393d2023-01-13 08:55:19 -060050
Andrew Geissler8f840682023-07-21 09:09:43 -050051CVE_STATUS[CVE-2007-4559] = "disputed: Upstream consider this expected behaviour"
52CVE_STATUS[CVE-2019-18348] = "not-applicable-config: This is not exploitable when glibc has CVE-2016-10739 fixed"
53CVE_STATUS[CVE-2020-15523] = "not-applicable-platform: Issue only applies on Windows"
54CVE_STATUS[CVE-2022-26488] = "not-applicable-platform: Issue only applies on Windows"
Andrew Geissler517393d2023-01-13 08:55:19 -060055# The module will be removed in the future and flaws documented.
Andrew Geissler8f840682023-07-21 09:09:43 -050056CVE_STATUS[CVE-2015-20107] = "upstream-wontfix: The mailcap module is insecure by design, so this can't be fixed in a meaningful way"
Andrew Geissler5082cc72023-09-11 08:41:39 -040057CVE_STATUS[CVE-2023-36632] = "disputed: Not an issue, in fact expected behaviour"
Andrew Geissler517393d2023-01-13 08:55:19 -060058
59PYTHON_MAJMIN = "3.11"
60
61S = "${WORKDIR}/Python-${PV}"
62
63BBCLASSEXTEND = "native nativesdk"
64
65inherit autotools pkgconfig qemu ptest multilib_header update-alternatives
66
67MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
68
69ALTERNATIVE:${PN}-dev = "python3-config"
70ALTERNATIVE_LINK_NAME[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config"
71ALTERNATIVE_TARGET[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}"
72
73
Andrew Geissler3eeda902023-05-19 10:14:02 -050074DEPENDS = "bzip2-replacement-native expat libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux-libuuid libtirpc libnsl2 autoconf-archive-native ncurses"
Andrew Geissler517393d2023-01-13 08:55:19 -060075DEPENDS:append:class-target = " python3-native"
76DEPENDS:append:class-nativesdk = " python3-native"
77
Andrew Geissler3eeda902023-05-19 10:14:02 -050078EXTRA_OECONF = " --without-ensurepip --enable-shared --with-platlibdir=${baselib} --with-system-expat"
Andrew Geissler517393d2023-01-13 08:55:19 -060079EXTRA_OECONF:append:class-native = " --bindir=${bindir}/${PN}"
80EXTRA_OECONF:append:class-target = " --with-build-python=nativepython3"
81EXTRA_OECONF:append:class-nativesdk = " --with-build-python=nativepython3"
82
83export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
84
85EXTRANATIVEPATH += "python3-native"
86
87# LTO will be enabled via packageconfig depending upong distro features
88LTO:class-target = ""
89
90CACHED_CONFIGUREVARS = " \
91 ac_cv_file__dev_ptmx=yes \
92 ac_cv_file__dev_ptc=no \
93 ac_cv_working_tzset=yes \
94"
Andrew Geissler5082cc72023-09-11 08:41:39 -040095# set thread stack size to 2MB on musl for interpreter and stdlib C extensions
96# so it does not run into stack limits due to musl's small thread stack
97# This is only needed to build interpreter and not the subsequent modules
98# Thats why CFLAGS_NODIST is modified instead of CFLAGS
99CACHED_CONFIGUREVARS:append:libc-musl = "\
100 CFLAGS_NODIST='${CFLAGS} -DTHREAD_STACK_SIZE=0x200000' \
101"
Andrew Geissler517393d2023-01-13 08:55:19 -0600102
103# PGO currently causes builds to not be reproducible so disable by default, see YOCTO #13407
Andrew Geissler3eeda902023-05-19 10:14:02 -0500104PACKAGECONFIG ??= "editline gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
105PACKAGECONFIG[readline] = "--with-readline=readline,,readline,,,editline"
Andrew Geissler517393d2023-01-13 08:55:19 -0600106PACKAGECONFIG[editline] = "--with-readline=editline,,libedit,,,readline"
107# Use profile guided optimisation by running PyBench inside qemu-user
108PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
109PACKAGECONFIG[tk] = ",,tk"
110PACKAGECONFIG[tcl] = ",,tcl"
111PACKAGECONFIG[gdbm] = ",,gdbm"
Andrew Geissler3eeda902023-05-19 10:14:02 -0500112PACKAGECONFIG[lto] = "--with-lto,--without-lto"
Andrew Geissler517393d2023-01-13 08:55:19 -0600113
114do_configure:prepend () {
115 mkdir -p ${B}/Modules
116 cat > ${B}/Modules/Setup.local << EOF
117*disabled*
118${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)}
119${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)}
120EOF
121}
122
123CPPFLAGS:append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"
124
125EXTRA_OEMAKE = '\
126 STAGING_LIBDIR=${STAGING_LIBDIR} \
127 STAGING_INCDIR=${STAGING_INCDIR} \
128 LIB=${baselib} \
129'
130
131do_compile:prepend:class-target() {
132 if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then
133 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}"
134 cat >pgo-wrapper <<EOF
135#!/bin/sh
136cd ${B}
137$qemu_binary "\$@"
138EOF
139 chmod +x pgo-wrapper
140 fi
141}
142
143do_install:prepend() {
144 ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile
145}
146
147do_install:append:class-target() {
148 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
149}
150
151do_install:append:class-native() {
152 # Make sure we use /usr/bin/env python
153 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
154 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
155 done
156 # Add a symlink to the native Python so that scripts can just invoke
157 # "nativepython" and get the right one without needing absolute paths
158 # (these often end up too long for the #! parser in the kernel as the
159 # buffer is 128 bytes long).
160 ln -s python3-native/python3 ${D}${bindir}/nativepython3
161
162 # Remove the opt-1.pyc and opt-2.pyc files. There are over 3,000 of them
163 # and the overhead in each recipe-sysroot-native isn't worth it, particularly
164 # when they're only used for python called with -O or -OO.
165 #find ${D} -name *opt-*.pyc -delete
166 # Remove all pyc files. There are a ton of them and it is probably faster to let
167 # python create the ones it wants at runtime rather than manage in the sstate
168 # tarballs and sysroot creation.
169 find ${D} -name *.pyc -delete
170
171 # Nothing should be looking into ${B} for python3-native
172 sed -i -e 's:${B}:/build/path/unavailable/:g' \
173 ${D}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile
174
175 # disable the lookup in user's site-packages globally
176 sed -i 's#ENABLE_USER_SITE = None#ENABLE_USER_SITE = False#' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py
177
178 # python3-config needs to be in /usr/bin and not in a subdir of it to work properly
179 mv ${D}/${bindir}/${PN}/python*config ${D}/${bindir}/
180}
181
182do_install:append() {
183 for c in ${D}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
184 python3 ${WORKDIR}/reformat_sysconfig.py $c
185 done
186 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/_sysconfigdata*.cpython*
187
188 mkdir -p ${D}${libdir}/python-sysconfigdata
189 sysconfigfile=`find ${D} -name _sysconfig*.py`
190 sed -i \
191 -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
192 -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
193 -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
194 -e "s,^ 'INCLUDEPY'.*, 'INCLUDEPY': '${STAGING_INCDIR}/python${PYTHON_MAJMIN}'\,,g" \
195 -e "s,^ 'CONFINCLUDEPY'.*, 'CONFINCLUDEPY': '${STAGING_INCDIR}/python${PYTHON_MAJMIN}'\,,g" \
196 -e "s,${B},/build/path/unavailable/,g" \
197 $sysconfigfile
198 cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
199
200
201 # Unfortunately the following pyc files are non-deterministc due to 'frozenset'
202 # being written without strict ordering, even with PYTHONHASHSEED = 0
203 # Upstream is discussing ways to solve the issue properly, until then let's
204 # just not install the problematic files.
205 # More info: http://benno.id.au/blog/2013/01/15/python-determinism
206 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_range.cpython*
207 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_xml_etree.cpython*
208
209 # Similar to the above, we're getting reproducibility issues with
210 # /usr/lib/python3.10/__pycache__/traceback.cpython-310.pyc
211 # so remove it too
212 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/traceback.cpython*
213
214 # Remove the opt-1.pyc and opt-2.pyc files. They effectively waste space on embedded
215 # style targets as they're only used when python is called with the -O or -OO options
216 # which is rare.
217 find ${D} -name *opt-*.pyc -delete
218}
219
220do_install:append:class-nativesdk () {
221 # Make sure we use /usr/bin/env python
222 for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
223 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
224 done
225 create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
226}
227
Andrew Geissler5082cc72023-09-11 08:41:39 -0400228do_install_ptest:append:class-target:libc-musl () {
229 sed -i -e 's|SKIPPED_TESTS=|SKIPPED_TESTS="-x test__locale -x test_c_locale_coercion -x test_locale -x test_os test_re -x test__xxsubinterpreters -x test_threading"|' ${D}${PTEST_PATH}/run-ptest
230}
231
Andrew Geissler517393d2023-01-13 08:55:19 -0600232SYSROOT_PREPROCESS_FUNCS:append:class-target = " provide_target_config_script"
233SYSROOT_PREPROCESS_FUNCS:append:class-nativesdk = " provide_target_config_script"
234
235# This is installed into /usr/python-target-config/ and not /usr/bin
236# because adding target sysroot's /usr/bin/ to PATH has unwanted side effects
237# in components erroneously picking up other target executables from it
238provide_target_config_script() {
239 install -d ${SYSROOT_DESTDIR}${prefix}/python-target-config/
240 install ${D}/${bindir}/python3-config ${SYSROOT_DESTDIR}/${prefix}/python-target-config/
241 install ${D}/${bindir}/python${PYTHON_MAJMIN}-config ${SYSROOT_DESTDIR}/${prefix}/python-target-config/
242}
243SYSROOT_DIRS += "${prefix}/python-target-config/"
244
245SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py"
246SSTATE_HASHEQUIV_FILEMAP = " \
247 populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${TMPDIR} \
248 populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${COREBASE} \
249 populate_sysroot:*/lib*/python3*/config-*/Makefile:${TMPDIR} \
250 populate_sysroot:*/lib*/python3*/config-*/Makefile:${COREBASE} \
251 populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${TMPDIR} \
252 populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${COREBASE} \
253 "
254PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
255
256py_package_preprocess () {
257 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
258 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
259 -e 's|${DEBUG_PREFIX_MAP}||g' \
260 -e 's:${HOSTTOOLS_DIR}/::g' \
261 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
262 -e 's:${RECIPE_SYSROOT}::g' \
263 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
264 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \
265 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
266 ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config
267
268 # Reformat _sysconfigdata after modifying it so that it remains
269 # reproducible
270 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
271 python3 ${WORKDIR}/reformat_sysconfig.py $c
272 done
273
274 # Recompile _sysconfigdata after modifying it
275 cd ${PKGD}
276 sysconfigfile=`find . -name _sysconfigdata_*.py`
277 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
278 -c "from py_compile import compile; compile('$sysconfigfile')"
279 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
280 -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)"
281 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
282 -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)"
283 cd -
284
285 mv ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}
286
287 #Remove the unneeded copy of target sysconfig data
288 rm -rf ${PKGD}/${libdir}/python-sysconfigdata
289}
290
291# We want bytecode precompiled .py files (.pyc's) by default
292# but the user may set it on their own conf
293INCLUDE_PYCS ?= "1"
294
295python(){
296 import collections, json
297
298 filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
299 # This python changes the datastore based on the contents of a file, so mark
300 # that dependency.
301 bb.parse.mark_dependency(d, filename)
302
303 with open(filename) as manifest_file:
304 manifest_str = manifest_file.read()
305 json_start = manifest_str.find('# EOC') + 6
306 manifest_file.seek(json_start)
307 manifest_str = manifest_file.read()
308 python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict)
309
310 # First set RPROVIDES for -native case
311 # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
312 pn = 'python3'
313 rprovides = (d.getVar('RPROVIDES') or "").split()
314
315 # ${PN}-misc-native is not in the manifest
316 rprovides.append(pn + '-misc-native')
317
318 for key in python_manifest:
319 pypackage = pn + '-' + key + '-native'
320 if pypackage not in rprovides:
321 rprovides.append(pypackage)
322
323 d.setVar('RPROVIDES:class-native', ' '.join(rprovides))
324
325 # Then work on the target
326 include_pycs = d.getVar('INCLUDE_PYCS')
327
328 packages = d.getVar('PACKAGES').split()
329 pn = d.getVar('PN')
330
331 newpackages=[]
332 for key in python_manifest:
333 pypackage = pn + '-' + key
334
335 if pypackage not in packages:
336 # We need to prepend, otherwise python-misc gets everything
337 # so we use a new variable
338 newpackages.append(pypackage)
339
340 # "Build" python's manifest FILES, RDEPENDS and SUMMARY
341 d.setVar('FILES:' + pypackage, '')
342 for value in python_manifest[key]['files']:
343 d.appendVar('FILES:' + pypackage, ' ' + value)
344
345 # Add cached files
346 if include_pycs == '1':
347 for value in python_manifest[key]['cached']:
348 d.appendVar('FILES:' + pypackage, ' ' + value)
349
350 for value in python_manifest[key]['rdepends']:
351 # Make it work with or without $PN
352 if '${PN}' in value:
353 value=value.split('-', 1)[1]
354 d.appendVar('RDEPENDS:' + pypackage, ' ' + pn + '-' + value)
355
356 for value in python_manifest[key].get('rrecommends', ()):
357 if '${PN}' in value:
358 value=value.split('-', 1)[1]
359 d.appendVar('RRECOMMENDS:' + pypackage, ' ' + pn + '-' + value)
360
361 d.setVar('SUMMARY:' + pypackage, python_manifest[key]['summary'])
362
363 # Prepending so to avoid python-misc getting everything
364 packages = newpackages + packages
365 d.setVar('PACKAGES', ' '.join(packages))
366 d.setVar('ALLOW_EMPTY:${PN}-modules', '1')
367 d.setVar('ALLOW_EMPTY:${PN}-pkgutil', '1')
368
369 if "pgo" in d.getVar("PACKAGECONFIG").split() and not bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d):
370 bb.fatal("pgo cannot be enabled as there is no qemu-usermode support for this architecture/machine")
371}
372
373# Files needed to create a new manifest
374
375do_create_manifest() {
376 # This task should be run with every new release of Python.
377 # We must ensure that PACKAGECONFIG enables everything when creating
378 # a new manifest, this is to base our new manifest on a complete
379 # native python build, containing all dependencies, otherwise the task
380 # wont be able to find the required files.
381 # e.g. BerkeleyDB is an optional build dependency so it may or may not
382 # be present, we must ensure it is.
383
384 cd ${WORKDIR}
385 # This needs to be executed by python-native and NOT by HOST's python
386 nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
387 cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
388}
389
390# bitbake python -c create_manifest
391# Make sure we have native python ready when we create a new manifest
392addtask do_create_manifest after do_patch do_prepare_recipe_sysroot
393
394# manual dependency additions
395RRECOMMENDS:${PN}-core:append:class-nativesdk = " nativesdk-python3-modules"
396RRECOMMENDS:${PN}-crypt:append:class-target = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
397RRECOMMENDS:${PN}-crypt:append:class-nativesdk = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
398
399# For historical reasons PN is empty and provided by python3-modules
400FILES:${PN} = ""
401RPROVIDES:${PN}-modules = "${PN}"
402
403FILES:${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
404FILES:${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
405
406# provide python-pyvenv from python3-venv
407RPROVIDES:${PN}-venv += "${MLPREFIX}python3-pyvenv"
408
409# package libpython3
410PACKAGES =+ "libpython3 libpython3-staticdev"
411FILES:libpython3 = "${libdir}/libpython*.so.*"
412FILES:libpython3-staticdev += "${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}-*/libpython${PYTHON_MAJMIN}.a"
413INSANE_SKIP:${PN}-dev += "dev-elf"
414INSANE_SKIP:${PN}-ptest = "dev-deps"
415
416# catch all the rest (unsorted)
417PACKAGES += "${PN}-misc"
418RDEPENDS:${PN}-misc += "\
Andrew Geissler8f840682023-07-21 09:09:43 -0500419 ${PN}-audio \
420 ${PN}-codecs \
Andrew Geissler517393d2023-01-13 08:55:19 -0600421 ${PN}-core \
422 ${PN}-email \
Andrew Geissler517393d2023-01-13 08:55:19 -0600423 ${PN}-numbers \
Andrew Geissler8f840682023-07-21 09:09:43 -0500424 ${PN}-pickle \
425 ${PN}-pydoc \
Andrew Geissler517393d2023-01-13 08:55:19 -0600426"
427RDEPENDS:${PN}-modules:append:class-target = " ${MLPREFIX}python3-misc"
428RDEPENDS:${PN}-modules:append:class-nativesdk = " ${MLPREFIX}python3-misc"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500429RDEPENDS:${PN}-modules:append:class-target = " ${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '${MLPREFIX}python3-gdbm', '', d)}"
Andrew Geissler517393d2023-01-13 08:55:19 -0600430FILES:${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload"
431
432# catch manpage
433PACKAGES += "${PN}-man"
434FILES:${PN}-man = "${datadir}/man"
435
436# See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395
437RDEPENDS:libpython3:append:libc-glibc = " libgcc"
438RDEPENDS:${PN}-ctypes:append:libc-glibc = " ${MLPREFIX}ldconfig"
Andrew Geissler5082cc72023-09-11 08:41:39 -0400439RDEPENDS:${PN}-ptest = "${PN}-modules ${PN}-tests ${PN}-dev ${PN}-cgitb ${PN}-zipapp unzip bzip2 libgcc tzdata coreutils sed gcc g++ binutils \
440 locale-base-fr-fr locale-base-en-us locale-base-de-de"
441RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-tr-tr"
Andrew Geissler517393d2023-01-13 08:55:19 -0600442RDEPENDS:${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${MLPREFIX}tk ${MLPREFIX}tk-lib', '', d)}"
443RDEPENDS:${PN}-idle += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${PN}-tkinter ${MLPREFIX}tcl', '', d)}"
444DEV_PKG_DEPENDENCY = ""
445RDEPENDS:${PN}-pydoc += "${PN}-io"
446
447RDEPENDS:${PN}-tests:append:class-target = " ${MLPREFIX}bash"
448RDEPENDS:${PN}-tests:append:class-nativesdk = " ${MLPREFIX}bash"
449
450# Python's tests contain large numbers of files we don't need in the recipe sysroots
451SYSROOT_PREPROCESS_FUNCS += " py3_sysroot_cleanup"
452py3_sysroot_cleanup () {
453 rm -rf ${SYSROOT_DESTDIR}${libdir}/python${PYTHON_MAJMIN}/test
454}