Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 1 | SUMMARY = "Reboot the device to a specific mode." |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 2 | |
| 3 | LICENSE = "GPL-3.0-or-later" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d" |
| 5 | |
| 6 | SRC_URI = "git://gitlab.com/postmarketOS/reboot-mode.git;protocol=http;branch=master" |
| 7 | SRCREV = "84831b20512abd9033414ca5f5a023f333525335" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | do_compile() { |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 12 | ${CC} ${CFLAGS} ${LDFLAGS} ${S}/reboot-mode.c -o ${B}/reboot-mode |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 13 | } |
| 14 | |
| 15 | do_install() { |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 16 | install -D -m 0755 ${B}/reboot-mode ${D}${bindir}/reboot-mode |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 17 | } |