blob: 444b97c4e64c865734833f111b0036a4bb178e93 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "display dialog boxes from shell scripts"
2DESCRIPTION = "Dialog lets you to present a variety of questions \
3or display messages using dialog boxes from a shell \
4script (or any scripting language)."
5HOMEPAGE = "http://invisible-island.net/dialog/"
6SECTION = "console/utils"
7DEPENDS = "ncurses"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008LICENSE = "LGPL-2.1-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
10
Andrew Geissler5082cc72023-09-11 08:41:39 -040011SRC_URI = "https://invisible-mirror.net/archives/${BPN}/${BP}.tgz"
12SRC_URI[sha256sum] = "0c26282305264be2217f335f3798f48b1dce3cf12c5a076bf231cadf77a6d6a8"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14# hardcoded here for use in dialog-static recipe
15S = "${WORKDIR}/dialog-${PV}"
16
17inherit autotools-brokensep pkgconfig
18
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050019PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
20
21PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11"
22
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023EXTRA_OECONF = "--with-ncurses \
24 --disable-rpath-hack"
25
26do_configure() {
27 gnu-configize --force
28 sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure
29 sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure
30 oe_runconf
31}