blob: 7db624a09b0b45b3e7aa7b449ae52a8d9c91c122 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "General purpose cryptographic library based on the code from GnuPG"
2HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4SECTION = "libs"
5
6# helper program gcryptrnd and getrandom are under GPL, rest LGPL
7LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+"
8LICENSE_${PN} = "LGPLv2.1+"
9LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+"
10LICENSE_dumpsexp-dev = "GPLv3+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
13 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \
14 file://LICENSES;md5=840e3bcb754e5046ffeda7619034cbd8"
15
16DEPENDS = "libgpg-error"
17
18UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
19SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
Brad Bishop64c979e2019-11-04 13:55:29 -050020 file://0001-libgcrypt-fix-m4-file-for-oe-core.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021 file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
22 file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
23 file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
Brad Bishop64c979e2019-11-04 13:55:29 -050024 file://0001-Prefetch-GCM-look-up-tables.patch \
25 file://0002-AES-move-look-up-tables-to-.data-section-and-unshare.patch \
26 file://0003-GCM-move-look-up-table-to-.data-section-and-unshare-.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027 file://determinism.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060029SRC_URI[sha256sum] = "03b70f028299561b7034b8966d7dd77ef16ed139c43440925fe8782561974748"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030
Andrew Geisslerd1e89492021-02-12 15:35:20 -060031# Below whitelisted CVEs are disputed and not affecting crypto libraries for any distro.
32CVE_CHECK_WHITELIST += "CVE-2018-12433 CVE-2018-12438"
33
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034BINCONFIG = "${bindir}/libgcrypt-config"
35
36inherit autotools texinfo binconfig-disabled pkgconfig
37
38EXTRA_OECONF = "--disable-asm"
39EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
40
41PACKAGECONFIG ??= "capabilities"
42PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
43
44do_configure_prepend () {
45 # Else this could be used in preference to the one in aclocal-copy
46 rm -f ${S}/m4/gpg-error.m4
47}
48
49# libgcrypt.pc is added locally and thus installed here
50do_install_append() {
51 install -d ${D}/${libdir}/pkgconfig
52 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
53}
54
55PACKAGES =+ "dumpsexp-dev"
56
57FILES_${PN}-dev += "${bindir}/hmac256"
58FILES_dumpsexp-dev += "${bindir}/dumpsexp"
59
60BBCLASSEXTEND = "native nativesdk"