Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "C bindings for apps which will manipulate JSON data" |
| 2 | DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C." |
| 3 | HOMEPAGE = "https://github.com/json-c/json-c/wiki" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2" |
| 6 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 7 | SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \ |
| 8 | file://run-ptest \ |
| 9 | " |
| 10 | SRC_URI[sha256sum] = "7550914d58fb63b2c3546f3ccfbe11f1c094147bd31a69dcd23714d7956159e6" |
| 11 | |
| 12 | # NVD uses full tag name including date |
| 13 | CVE_VERSION = "0.17-20230812" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 15 | UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/tags" |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 16 | UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+)-\d+" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | RPROVIDES:${PN} = "libjson" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 20 | # Required for ICECC builds |
| 21 | EXTRA_OECMAKE = "-DDISABLE_WERROR=ON" |
| 22 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 23 | inherit cmake ptest |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | install -d ${D}/${PTEST_PATH}/tests |
| 27 | install ${B}/tests/test* ${D}/${PTEST_PATH}/tests |
| 28 | install ${S}/tests/*.test ${D}/${PTEST_PATH}/tests |
| 29 | install ${S}/tests/*.expected ${D}/${PTEST_PATH}/tests |
| 30 | install ${S}/tests/test-defs.sh ${D}/${PTEST_PATH}/tests |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 31 | install ${S}/tests/*json ${D}/${PTEST_PATH}/tests |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 32 | } |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | |
| 34 | BBCLASSEXTEND = "native nativesdk" |