Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API." |
| 2 | DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \ |
| 3 | libxslt libraries. It provides safe and convenient access to these \ |
| 4 | libraries using the ElementTree API. It extends the ElementTree API \ |
| 5 | significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \ |
| 6 | C14N and much more." |
| 7 | HOMEPAGE = "http://codespeak.net/lxml" |
| 8 | SECTION = "devel/python" |
| 9 | LICENSE = "BSD & GPLv2 & MIT & PSF" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \ |
| 12 | file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \ |
| 13 | file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \ |
| 16 | file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | " |
| 18 | |
| 19 | DEPENDS += "libxml2 libxslt" |
| 20 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 21 | SRC_URI[sha256sum] = "39b78571b3b30645ac77b95f7c69d1bffc4cf8c3b157c435a34da72e78c82468" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 22 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame^] | 23 | inherit pkgconfig pypi setuptools3 |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame] | 25 | # {standard input}: Assembler messages: |
| 26 | # {standard input}:1488805: Error: branch out of range |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | DEBUG_OPTIMIZATION:remove:mips = " -Og" |
| 28 | DEBUG_OPTIMIZATION:append:mips = " -O" |
| 29 | BUILD_OPTIMIZATION:remove:mips = " -Og" |
| 30 | BUILD_OPTIMIZATION:append:mips = " -O" |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame] | 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | DEBUG_OPTIMIZATION:remove:mipsel = " -Og" |
| 33 | DEBUG_OPTIMIZATION:append:mipsel = " -O" |
| 34 | BUILD_OPTIMIZATION:remove:mipsel = " -Og" |
| 35 | BUILD_OPTIMIZATION:append:mipsel = " -O" |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame] | 36 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 37 | BBCLASSEXTEND = "native nativesdk" |
| 38 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | RDEPENDS:${PN} += "libxml2 libxslt ${PYTHON_PN}-compression" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 40 | |
| 41 | CLEANBROKEN = "1" |