Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Extensible memoizing collections and decorators" |
| 2 | HOMEPAGE = "https://github.com/tkem/cachetools" |
| 3 | DESCRIPTION = "This module provides various memoizing \ |
| 4 | collections and decorators, including variants of the \ |
| 5 | Python 3 Standard Library @lru_cache function decorator." |
| 6 | SECTION = "devel/python" |
| 7 | |
| 8 | LICENSE = "MIT" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1ec55353c80c662e4255f8889a0ca558" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | |
| 11 | inherit pypi python_setuptools_build_meta ptest |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
| 17 | RDEPENDS:${PN} += " \ |
| 18 | ${PYTHON_PN}-math \ |
| 19 | " |
| 20 | |
| 21 | RDEPENDS:${PN}-ptest += " \ |
| 22 | ${PYTHON_PN}-pytest \ |
| 23 | " |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | install -d ${D}${PTEST_PATH}/tests |
| 27 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 28 | } |
| 29 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 30 | SRC_URI[sha256sum] = "dce83f2d9b4e1f732a8cd44af8e8fab2dbe46201467fc98b3ef8f269092bf62b" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |