Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "A multi-platform support library with a focus on asynchronous I/O" |
| 2 | HOMEPAGE = "https://github.com/libuv/libuv" |
| 3 | DESCRIPTION = "libuv is a multi-platform support library with a focus on asynchronous I/O. It was primarily developed for use by Node.js, but it's also used by Luvit, Julia, pyuv, and others." |
| 4 | BUGTRACKER = "https://github.com/libuv/libuv/issues" |
| 5 | LICENSE = "MIT" |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame^] | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=74b6f2f7818a4e3a80d03556f71b129b \ |
| 7 | file://LICENSE-extra;md5=f9307417749e19bd1d6d68a394b49324" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 9 | SRCREV = "96e05543f53b19d9642b4b0dd73b86ad3cea313e" |
| 10 | SRC_URI = "git://github.com/libuv/libuv.git;branch=master;protocol=https" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit autotools |
| 16 | |
| 17 | do_configure() { |
| 18 | ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh" |
| 19 | oe_runconf |
| 20 | } |
| 21 | |
| 22 | BBCLASSEXTEND = "native" |