blob: eb7ba1089f64c9df421eeee265d2a68033c8871c [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "VirGL virtual OpenGL renderer"
2DESCRIPTION = "Virgil is a research project to investigate the possibility of \
3creating a virtual 3D GPU for use inside qemu virtual machines, that allows \
4the guest operating system to use the capabilities of the host GPU to \
5accelerate 3D rendering."
6HOMEPAGE = "https://virgil3d.github.io/"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING;md5=c81c08eeefd9418fca8f88309a76db10"
10
11DEPENDS = "libdrm libepoxy virtual/egl virtual/libgbm"
Patrick Williamsda295312023-12-05 16:48:56 -060012SRCREV = "9c9d55ecbe502e0d71ee99529709efcca69aac42"
13SRC_URI = "git://gitlab.freedesktop.org/virgl/virglrenderer.git;branch=main;protocol=https \
Andrew Geissler517393d2023-01-13 08:55:19 -060014 file://0001-meson.build-use-python3-directly-for-python.patch \
Patrick Williamsda295312023-12-05 16:48:56 -060015 file://0001-vtest-Fix-undefined-behavior-with-clang.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060016 "
17
18S = "${WORKDIR}/git"
19
20inherit meson pkgconfig features_check
21
Patrick Williamsda295312023-12-05 16:48:56 -060022PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', 'venus', '', d)}"
Andrew Geissler517393d2023-01-13 08:55:19 -060023
Patrick Williamsda295312023-12-05 16:48:56 -060024PACKAGECONFIG[venus] = "-Dvenus=true,-Dvenus=false,vulkan-loader vulkan-headers"
Andrew Geissler517393d2023-01-13 08:55:19 -060025PACKAGECONFIG[va] = "-Dvideo=true,-Dvideo=false,libva"
26PACKAGECONFIG[render-server] = "-Drender-server=true,-Drender-server=false"
27PACKAGECONFIG[drm-msm-experimental] = "-Ddrm-msm-experimental=true,-Ddrm-msm-experimental=false"
28PACKAGECONFIG[minigbm_allocation] = "-Dminigbm_allocation=true,-Dminigbm_allocation=false"
29PACKAGECONFIG[venus-validate] = "-Dvenus-validate=true,-Dvenus-validate=false"
30PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,libcheck"
31
32BBCLASSEXTEND = "native nativesdk"
33
34REQUIRED_DISTRO_FEATURES = "opengl"