blob: 9170cf875322297fea4e726dfd47b9ab695ef50e [file] [log] [blame]
Naveen Mosesc8d90aa2021-10-07 18:20:33 +05301FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
Patrick Williamsd5c716d2022-02-17 07:30:57 -06003SRC_URI:append:fb-withhost = " file://set-bmc-time-from-host"
Naveen Mosesc8d90aa2021-10-07 18:20:33 +05304
5
Patrick Williamsd5c716d2022-02-17 07:30:57 -06006RDEPENDS:${PN}:append:fb-withhost = " bash"
Naveen Mosesc8d90aa2021-10-07 18:20:33 +05307
8do_install:append:fb-withhost(){
9
10 # Store the bitbake variable OBMC_HOST_INSTANCES inside time sync script as HOST_INSTANCES variable using sed.
11 sed -i -e "s,HOST_INSTANCES_SED_REPLACEMENT_VALUE,${OBMC_HOST_INSTANCES},g" ${WORKDIR}/set-bmc-time-from-host
12
13 install -d ${D}$/lib/systemd/system
14 install -m 0644 ${WORKDIR}/bmc-set-time.service ${D}$/lib/systemd/system
Patrick Williamsedf8fe52023-03-24 09:46:00 -050015 install -d ${D}${libexecdir}
Patrick Williamsd3135242024-01-19 16:45:58 -060016 install -m 0755 ${WORKDIR}/set-bmc-time-from-host ${D}${libexecdir}
Naveen Mosesc8d90aa2021-10-07 18:20:33 +053017}
18
19SYSTEMD_SERVICE:${PN}:fb-withhost += "bmc-set-time.service"