blob: 5bffa22918bed79c95367cd7631d95b2aafaebdf [file] [log] [blame]
Andrew Geissler220dafd2023-10-04 10:18:08 -05001SUMMARY = "APIFlask is a lightweight Python web API framework based on Flask and marshmallow-code projects."
2HOMEPAGE = "https://github.com/apiflask/apiflask"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5f89d1b0dec37448d4f4163dc3c40e64"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "APIFlask"
9
Patrick Williams169d7bc2024-01-05 11:33:25 -060010SRC_URI[sha256sum] = "e7616d902d446eb9e1c67d1d8a34691b437f9da4fe7a3b4d49c91ba88c85ee2a"
Andrew Geissler220dafd2023-10-04 10:18:08 -050011
12RDEPENDS:${PN} += "\
13 python3-flask \
14 python3-flask-marshmallow \
15 python3-webargs \
16 python3-flask-httpauth \
17 python3-apispec \
18 "