Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 1 | SUMMARY = "IBM enhanced error logging" |
| 2 | DESCRIPTION = "Adds additional error logging functionality for IBM systems" |
| 3 | PR = "r1" |
Patrick Venture | 18823e6 | 2018-10-26 09:39:44 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 5 | HOMEPAGE = "https://github.com/openbmc/ibm-logging" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | SRC_URI += "git://github.com/openbmc/ibm-logging" |
Andrew Geissler | 2927ac0 | 2021-04-14 13:30:16 +0000 | [diff] [blame] | 9 | SRCREV = "074d53b723a26a50b628387c635a97c730555bce" |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 10 | |
| 11 | inherit autotools |
| 12 | inherit pkgconfig |
Matt Spinler | 1a9ef19 | 2020-02-20 10:56:34 -0600 | [diff] [blame] | 13 | inherit python3native |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 14 | inherit obmc-phosphor-dbus-service |
| 15 | inherit obmc-phosphor-systemd |
Matt Spinler | 1739501 | 2018-03-28 14:00:19 -0500 | [diff] [blame] | 16 | inherit phosphor-dbus-yaml |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 17 | |
| 18 | DEPENDS += " \ |
Patrick Williams | 20a9cf3 | 2020-06-12 12:10:52 -0500 | [diff] [blame] | 19 | ${PYTHON_PN}-pyyaml-native \ |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 20 | autoconf-archive-native \ |
Matt Spinler | de04acf | 2020-06-16 16:15:43 -0500 | [diff] [blame] | 21 | phosphor-dbus-interfaces \ |
Patrick Williams | 20a9cf3 | 2020-06-12 12:10:52 -0500 | [diff] [blame] | 22 | nlohmann-json \ |
| 23 | phosphor-logging \ |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 24 | sdbusplus \ |
| 25 | " |
| 26 | |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 27 | S = "${WORKDIR}/git" |
| 28 | |
| 29 | SRC_URI += "file://policyTable.json" |
| 30 | |
| 31 | PACKAGECONFIG ??= "" |
| 32 | PACKAGECONFIG[policy-interface] = "--enable-policy-interface, --disable-policy-interface,," |
| 33 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 34 | PACKAGECONFIG:ibm-ac-server = "policy-interface" |
| 35 | PACKAGECONFIG:mihawk = "policy-interface" |
Brad Bishop | e161514 | 2020-04-22 14:06:02 -0400 | [diff] [blame] | 36 | |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 37 | SERVICE = "com.ibm.Logging.service" |
Patrick Williams | 57b7624 | 2021-08-11 15:27:06 -0500 | [diff] [blame^] | 38 | DBUS_SERVICE:${PN} += "${SERVICE}" |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 39 | |
| 40 | #The link is so that this service will restart if phosphor-logging restarts. |
| 41 | #The BindsTo in the service will not do the restart, it will only do the |
| 42 | #original start and a stop. |
| 43 | LOG_FMT = "../${SERVICE}:xyz.openbmc_project.Logging.service.wants/${SERVICE}" |
| 44 | SYSTEMD_LINK_${PN} += "${LOG_FMT}" |
| 45 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 46 | do_install:append(){ |
Matt Spinler | 575b0c0 | 2018-03-28 12:59:43 -0500 | [diff] [blame] | 47 | |
| 48 | install -d ${D}${datadir}/ibm-logging |
| 49 | |
| 50 | ${S}/condense_policy.py \ |
| 51 | -p ${WORKDIR}/policyTable.json \ |
| 52 | -c ${D}/${datadir}/ibm-logging/policy.json |
| 53 | } |
Matt Spinler | 1739501 | 2018-03-28 14:00:19 -0500 | [diff] [blame] | 54 | |
| 55 | #An optional task to generate a report on all of the errors |
| 56 | #created by OpenBMC, and compare these errors to what is |
| 57 | #in the error policy table |
| 58 | do_report(){ |
| 59 | |
| 60 | ${S}/create_error_reports.py \ |
| 61 | -p ${D}/${datadir}/ibm-logging/policy.json \ |
Patrick Williams | 20a9cf3 | 2020-06-12 12:10:52 -0500 | [diff] [blame] | 62 | -y ${STAGING_DIR_TARGET}${yaml_dir} \ |
Matt Spinler | 1739501 | 2018-03-28 14:00:19 -0500 | [diff] [blame] | 63 | -e ${WORKDIR}/build/all_errors.json \ |
| 64 | -x ${WORKDIR}/build/policy_crosscheck.txt |
| 65 | |
| 66 | } |
| 67 | |
Patrick Williams | 20a9cf3 | 2020-06-12 12:10:52 -0500 | [diff] [blame] | 68 | addtask report after do_install |