Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap" |
| 2 | DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \ |
| 3 | bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \ |
| 4 | and copying files using the block map. The idea is that large file containing \ |
| 5 | unused blocks, like raw system image files, can be copied or flashed a lot \ |
| 6 | faster with bmaptool than with traditional tools like "dd" or "cp"." |
| 7 | HOMEPAGE = "https://github.com/01org/bmap-tools" |
| 8 | SECTION = "console/utils" |
| 9 | LICENSE = "GPLv2" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 11 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 12 | SRC_URI = "git://github.com/intel/${BPN};branch=master;protocol=https" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 14 | SRCREV = "c0673962a8ec1624b5189dc1d24f33fe4f06785a" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | PV .= "+git${SRCPV}" |
| 17 | |
| 18 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 19 | |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 20 | # Need df from coreutils |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | RDEPENDS:${PN} = "python3-core python3-compression python3-mmap python3-setuptools python3-fcntl python3-six coreutils" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
| 23 | inherit python3native |
| 24 | inherit setuptools3 |
| 25 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 26 | BBCLASSEXTEND = "native nativesdk" |