blob: f95fce3b08f0d6883ba6704ba3f8919fa1c36521 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A module wrapper for os.path"
2LICENSE = "MIT"
Patrick Williams2a254922023-08-11 09:48:11 -05003LIC_FILES_CHKSUM = "file://LICENSE;md5=141643e11c48898150daa83802dbc65f"
Andrew Geissler517393d2023-01-13 08:55:19 -06004
Patrick Williams73bd93f2024-02-20 08:07:48 -06005SRC_URI[sha256sum] = "b32b22b76fe810a8ded6d136268cc8b6698ae7c47c29b94a9ea12623f3051e46"
Andrew Geissler517393d2023-01-13 08:55:19 -06006
Patrick Williams8e7b46e2023-05-01 14:19:06 -05007SRC_URI += "\
Patrick Williams520786c2023-06-25 16:20:36 -05008 file://run-ptest \
Patrick Williams8e7b46e2023-05-01 14:19:06 -05009"
10
11inherit pypi python_setuptools_build_meta ptest
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13DEPENDS += "python3-setuptools-scm-native"
14
Patrick Williams8e7b46e2023-05-01 14:19:06 -050015RDEPENDS:${PN} += " \
Patrick Williams520786c2023-06-25 16:20:36 -050016 python3-appdirs \
17 python3-crypt \
18 python3-io \
19 python3-numbers \
20 python3-shell \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050021"
22RDEPENDS:${PN}-ptest += " \
Patrick Williams520786c2023-06-25 16:20:36 -050023 python3-pytest \
24 python3-unittest-automake-output \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050025"
26
Andrew Geissler517393d2023-01-13 08:55:19 -060027BBCLASSEXTEND = "nativesdk native"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050028
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/test
31 cp -rf ${S}/test_* ${D}${PTEST_PATH}/test/
32 install -d ${D}${PTEST_PATH}/path
33 cp -rf ${S}/path/* ${D}${PTEST_PATH}/path/
34}