Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Physical quantities module" |
| 2 | DESCRIPTION = "Physical quantities Python module" |
| 3 | HOMEPAGE = "https://github.com/hgrecco/pint" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b" |
| 8 | |
| 9 | PYPI_PACKAGE := "Pint" |
| 10 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | inherit pypi ptest python_setuptools_build_meta |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | |
| 15 | DEPENDS += "python3-setuptools-scm-native" |
| 16 | |
| 17 | BBCLASSEXTEND = "native nativesdk" |
| 18 | |
| 19 | SRC_URI += " \ |
| 20 | file://run-ptest \ |
| 21 | " |
| 22 | |
| 23 | RDEPENDS:${PN} += " \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 24 | python3-setuptools \ |
| 25 | python3-packaging \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 26 | " |
| 27 | |
| 28 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 29 | python3-pytest \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 30 | " |
| 31 | |
| 32 | do_install_ptest() { |
| 33 | install -d ${D}${PTEST_PATH}/testsuite |
| 34 | cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/ |
| 35 | } |