Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "A small Python module for determining appropriate platform-specific dirs" |
| 2 | HOMEPAGE = "https://github.com/platformdirs/platformdirs" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a" |
| 5 | |
| 6 | SRC_URI += " \ |
| 7 | file://run-ptest \ |
| 8 | " |
| 9 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "ef0cc731df711022c174543cb70a9b5bd22e5a9337c8624ef2c2ceb8ddad8768" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 11 | |
| 12 | inherit pypi python_hatchling ptest |
| 13 | |
| 14 | DEPENDS += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 15 | python3-hatch-vcs-native \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 19 | python3-appdirs \ |
| 20 | python3-covdefaults \ |
| 21 | python3-pytest \ |
| 22 | python3-pytest-cov \ |
| 23 | python3-pytest-mock \ |
| 24 | python3-unittest-automake-output \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 25 | " |
| 26 | |
| 27 | do_install_ptest() { |
| 28 | install -d ${D}${PTEST_PATH} |
| 29 | cp -rf ${S}/tests ${D}${PTEST_PATH}/ |
| 30 | } |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |