Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "A Python implementation of Google's Encoded Polyline Algorithm Format" |
| 2 | HOMEPAGE = "https://github.com/frederickjansen/polyline" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1fb8d1dc685695195bb3c1e48adfef48" |
| 5 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "10541e759c5fd51f746ee304e9af94744089a4055b6257b293b3afd1df64e369" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 7 | |
| 8 | inherit pypi python_setuptools_build_meta ptest |
| 9 | |
| 10 | RDEPENDS:${PN} += "python3-six" |
| 11 | |
| 12 | BBCLASSEXTEND = "native nativesdk" |
| 13 | |
| 14 | SRC_URI += " \ |
| 15 | file://run-ptest \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 19 | python3-pytest \ |
| 20 | python3-unittest-automake-output \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 21 | " |
| 22 | |
| 23 | do_install_ptest() { |
| 24 | install -d ${D}${PTEST_PATH}/test |
| 25 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/test/ |
| 26 | } |