blob: 00cb51be41ada5202bc39969a5a1bc1d46f340fd [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A Python implementation of Google's Encoded Polyline Algorithm Format"
2HOMEPAGE = "https://github.com/frederickjansen/polyline"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1fb8d1dc685695195bb3c1e48adfef48"
5
Patrick Williams39653562024-03-01 08:54:02 -06006SRC_URI[sha256sum] = "10541e759c5fd51f746ee304e9af94744089a4055b6257b293b3afd1df64e369"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06007
8inherit pypi python_setuptools_build_meta ptest
9
10RDEPENDS:${PN} += "python3-six"
11
12BBCLASSEXTEND = "native nativesdk"
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-pytest \
20 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060021"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/test
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/test/
26}